Jump to content
Enpass Discussion Forum

Programie

Members
  • Posts

    21
  • Joined

  • Last visited

  • Days Won

    6

Posts posted by Programie

  1. In my previous post I only tested it in the way of quitting Enpass and manually starting it with the "-minimize" option which worked as already described. But I still got the issue after login.

    After some time trying to find out what exactly causes the issue, I tried to remove the startup entry completely. But Enpass still started on login even if it should not as there is no startup entry.

    Then I figured out that KDE by default saves the opened application in the session and restores them after login. But in that case, Enpass is started with "-session <some long session id>" instead of the "-minimize" option which obviously results in having the main window visible on start.

    I've now configured KDE to always start a clean session on login without restoring previous opened applications and re-enabled the "Open Automatically at System Startup" option in Enpass. Now Enpass is starting with only the tray icon visible.

    There is also an option to exclude specific application from session restoration, so excluding Enpass from the session restoration should also work. But in my case, I keep the session restoration completely disabled.

  2. There is another topic asking for SSH Agent support. Unfortunately, the topic has been already closed without further information whether this will be implemented or not.

    I would really love to have SSH Agent support in Enpass.

    My expected behavior of this implementation would be Enpass asking me to unlock the Vault once an SSH Agent request is made (just like auto fill in the browser extension) and then accepting the SSH Agent connection.

    Is this on the list to be implemented?

    • Like 8
  3. I'm using Enpass 6 on Linux with Google Chrome (unstable). On some websites, auto filling the login form results in filling in the form and reloading the page instead of posting the form.

    Opening the same page on a new tab temporarily solves the issue but after some time it occurs again.

    I'm not sure whether this is an issue with the Enpass extension or Chrome.

    I also did some debugging:

    • There is no POST request (which is done when submitting the same login form on another tab). The page is simply reloaded.
    • Auto filling in an entry stored for another page results in filling in the user and password from the other page and then loading the other page (e.g. I'm on page A, select an entry for page B from Enpass to auto fill, username and password from page B is autofilled (without submitting the login form) and then the URL of page B is loaded)
    • Like 1
  4. When configuring Enpass to automatically start on login, the Enpass main window is visible.

    Is there any way to start Enpass just showing the tray icon without showing the main window?

    I'm using Enpass 6.0.1 on Ubuntu 18.10 with KDE.

    • Like 2
  5. As far as I know, Enpass is secure while your vault is locked (i.e. asking for the master password). Therefore you shouldn't set the lock timeout of Enpass to a high value (or completely disable it) or at least manually lock it if Enpass is not currently in use. In my case I've set the auto lock to 1 minute of Enpass inactivity.

    • Like 1
    • Thanks 1
  6. 6 hours ago, Akash Vyas said:

    This is a known behavior when you set Enpass to run on system startup instead of enabling it from Enpass Settings.

    That's exactly what I did.

    I just removed the entry from the KDE Autostart and re-enabled it in Enpass settings again. However Enpass just created exactly the same entry with the same command (/opt/Enpass/bin/runenpass.sh startWithTray).

  7. I'm using Enpass on Ubuntu 17.04 with KDE. Enpass is automatically started on startup using the KDE autostart.

    On every boot, Enpass shows me an error "Sqlcipher driver not found". The same issue happens whenever I start Enpass from Latte Dock. But it works when I start it from the KDE application menu.

    In case of the KDE autostart, Enpass is started using "/opt/Enpass/bin/runenpass.sh startWithTray". If I execute that directly, it works. But why doesn't it work when started on login?

    is that an issue with Enpass or am I just doing something wrong?

     

    Details:

    Description:    Sqlcipher driver not found.
    Database Path:    /home/programie/Documents/Enpass/walletx.db
    Drive Type:    /dev/sda5
    Accessible    True
    Writable:    True
    Keyboard Layout:    English
    Enpass / Operating System version:    5.5.6 / Ubuntu 17.04

  8. I think two factor authentication is primarily useful for preventing brute force attacks. So if an attacker guesses the password for your account, they still have to find out the TOTP token in a short period of time which is pretty impossible. OK you could also find out the TOTP secret...

    In case of GitHub I just saw this notice after configuring Two factor Authentication for my account: Treat your recovery codes with the same level of attention as you would your password! We recommend saving them with a password manager such as Lastpass, 1Password, or Keeper.

    So if you are storing the recovery codes in the password manager, storing the TOTP secret in the password manager as well does not change anything in the security.

  9. On 5/26/2016 at 1:42 PM, edenhaus said:

    I would be of course a nice feature, but I think it's very hard to implement, because how you want to check if the provider was hacked or not. I think you must check on security website, which provider was hacked.

    As I have written above it would be perfect, that you can specify the time peroid. Because for me 1-2 years is to long and risky

    1Password has such a feature (it's called Watch Tower). So, it's possible. ;)

×
×
  • Create New...