Jump to content
rugen

Unable to sync

Recommended Posts

Hey,

since about 2-3 months I can't sync my DB anymore. In the beginning I thought it's a problem due my MacBook / iPhone or webDAV-syncing on my Synology NAS, but yesterday I found time to test it and came to the conclusion, that it must be an issue of Enpass.

My setting:

  • MacBook Pro with macOS 10.12.6 (Sierra)
  • iPhone 6 with iOS 10.3.3
  • Synology DS215j with DSM 6.1.3-15152 Update 3; firewall deactivated; local network; Let's Encrypt certificate
  • Enpass 5.5.8 (101) 

Before the issue begun I used to sync my DB via webDAV onto my NAS. Everything worked perfect. From one day to the next it just stopped working. When I try to sync I don't get an error message, it just doesn't work and the old timestamp stays. Strangely it works when I delete the DB-file manually before syncing.

I've tested the following things:

  • Sync via webDAV (HTTP and HTTPS) on my NAS 
  • Sync via webDAV (HTTP and HTTPS) on my NAS from a Windows 10 laptop
  • Sync via webDAV (HTTP) to a clean-installed apache server on a raspberry pi
  • Sync via webDAV (HTTP) to a clean-installed apache server on a raspberry pi from a Windows 10 laptop
  • Sync to a local folder on my Mac
  • Re-install the DSM on my NAS
  • Re-install Enpass on my Mac and iPhone
  • Sync an empty DB (webDAV and local folder)

 

I'm at my wit's end and I hope you can help me. Many thanks in advance!

Your rugen

-----

Please excuse my poor English.

 

Edited by rugen

Share this post


Link to post
Share on other sites
Guest Akash Vyas

Hey @rugen

Thanks for the detailed explanation.

This might just be a misinterpretation, Last Synchronized and Last Attempt are two different timings. Last Synchronized shows the interval when the latest successful data is synced and file update on the cloud. While the Last Attempt shows the time interval for the latest check for changes. So there might be different time intervals for both timings.


For Testing Purpose: Make some sample changes in one device like mark any item to favorite, add a new item, add a new folder. Now check if the changes are reflected on other devices and make sure Date and Time are same (preferably, set it to automatic) on all devices.

Cheers!

Share this post


Link to post
Share on other sites

in my case it really does not synchronise - I just made "test change", even reconfigured connection again but still the same:

 

 

Screen Shot 2017-09-30 at 08.32.26.png

Share this post


Link to post
Share on other sites

Hi @zyghom

Sorry to hear about your trouble you are going through.

The reason behind getting error 116 is that Enpass is not able to upload changes to cloud so please make sure your internet connection is stable and Date & Time settings set to automatic.

If the problem persists, it would be a great help if you can PM a demo account of WebDAV along with OS and Enpass version you are using, so that we can diagnose where the problem could be.

Thanks for your co-operation!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...