Jump to content
sxc4567

Enpass 6.5.0 MUCH more stable but crashes still

Recommended Posts

Hi there,

A massive THANK YOU for the release of beta 6.5.0 for Linux.  I have documented the excruciating experience I had with the previous version (6.4.1) on stock Ubuntu 20.04, which was crashing up to 20 times a day on me!

As soon as I saw news of the 6.5.0 beta, I didn't hesitate one second.  The outcome: it's a massive improvement in stability as it only crashes maybe once a day on average; I probably use Enpass 20-30 times a day on my desktop.

Still, once a day is not fully satisfactory; thus my queries:

  1. Is there any practical way I can help you debug these issues whilst the beta is being finalized?  I've been sending those crash reports; you much have an absolute pile of them from me.
  2. Re the crash reports: PLEASE, can we have an option to turn these off?  I don't believe the 100th crash report is going to add much value to the 99 before it and when Enpass is having a bad day, having to wait for them to gather their data and click through them increases the frustration manifold.
Edited by sxc4567

Share this post


Link to post
Share on other sites

Hey @sxc4567

We are extremely sorry for the trouble you have been facing from a long time.

23 hours ago, sxc4567 said:

Is there any practical way I can help you debug these issues whilst the beta is being finalized?  I've been sending those crash reports; you much have an absolute pile of them from me.

Enable Logs in the Advanced Settings. If Enpass crashes again, copy logs and send to us directly. To do so, you can share the logs by following the steps-  Open Enpass > Settings > Advanced > Enable logs and when Enpass crashes, copy logs and send to us.  

23 hours ago, sxc4567 said:

Re the crash reports: PLEASE, can we have an option to turn these off?  I don't believe the 100th crash report is going to add much value to the 99 before it and when Enpass is having a bad day, having to wait for them to gather their data and click through them increases the frustration manifold.

Apologies for the trouble. We just improved our crash reporting system in 6.5 release. Make sure description must be entered. You can send the description info also in the form of screenshot or plain text via email at support@enpass.io or via massage from forum post. Also, please share the below detail to identify the issue better-

  • Size of database?
  • Number of items and attachment?
  • Wayland or Gnome?
  • Any particular scenario where Enpass crashes?
  • Does it crash at the start of the day?
  • Does it crash after you update system?
  • Locking time?
  • Build No. of Ubuntu 20.04 is it 20.04 or 20.04.1?

Thanks for the co-operation!

Share this post


Link to post
Share on other sites

Hi @Garima Singh,

Thanks again for following up.  It's really good to see that you care about your Linux users.  I have enabled logs and will email support@enpass.io with logs upon the next crash.  Here's my answer to your generic questions:

  • Size of database? I have 4 vaults, all synchronized with the iOS mobile version using a local WebDav server.  Not sure
    • vault #1: 1.1MB, 324 items, 4 attachments (1.5MB in total); #2: 411kB 165 items, 1 attachment (5kB); #3: 70kB, 14 items, no attachments; #4: 66kB, 12 items, no attachments
  • I run standard Ubuntu 20.04.1, fully up-to-date; Gnome, X11, not Wayland. 
    • I run Enpass at system startup.  I have to run it with `QT_AUTO_SCREEN_SCALE_FACTOR=0 QT_SCREEN_SCALE_FACTORS=1` (as documented in your support articles) to prevent it from being huge on my screen.
    • One thing I do which might possibly contribute to the issue (?) is using multiple workspaces.  I typically set Enpass to be "Always on visible workspace", so it can be invoked from whichever workspace I happen to be working on.
  • Scenarios: Enpass typically crashes when invoked from Firefox (again, standard, up-to-date build, which is currently 80.0.1), when using a hotkey from a login form.  The crashes can occur in a variety of scenarios, eg:
    • before I even see the Enpass UI (so Firefox displays the "looking for Enpass app" page; and usually this takes a while and I often but not always get to see the crash reporter)
    • before I interact with the UI; for example while I use the search box to look up an entry
    • just as it's filling out the form
    • and sometimes just after filling out the form. 
    • Previously (with v6.4.1) Enpass would crash so often that there were no observable pattern; sometimes it would crash at the start of the day, ie: just after waking up my laptop from ACPI sleep, but this seems to have improved with 6.5.0.  So far with v6.5.0, the pattern appears to be related to filling out forms from Firefox.
  • I haven't observed a correlation of crashes with system updates.
  • Locking time? Do you mean Enpass locking?  I have the following options enabled:
    • When main window is closed
    • System sleeps
    • System is inactive for 2 minutes
    • I also have the PIN option set

I hope this is useful; I'll be sure to follow up with logs as/when Enpass crashes next time.  I still think there ought to be an option to switch off the crash reporter; having had to suffer it for over 6 months before 6.5.0 came out was really no fun, I can assure you!

Edited by sxc4567

Share this post


Link to post
Share on other sites

Hi @Garima Singh,

I got an update to version 6.5.1.719 (beta) and it's *significantly worse* than the previous version (6.5.0.707).  6.5.0 would crash about once a day; 6.5.1.719 is back to crashing at least 10 times a day.  I've just had a crash, followed by an immediate second crash just after typing the master password.

I would strongly advise a rollback of 6.5.1.719.

I also looked into the "logs" which I enabled, inside the Enpass app.  All I get are a number of "info" entries logging interactions with the WebDav server where my vaults are stored ().  They don't look very useful to me but I can send them across if that's helpful.

PLEASE can we get the option to disable the automatic crash reporter? (make it default to submit the reports if you like).  I can't believe that the 101th crash report I submitted is more useful than the 100 previous ones and this thing makes a bad situation much worse in terms of frustrating one's workflow with Enpass so long as it continues to crash as often.

Share this post


Link to post
Share on other sites

I'm having to share some passwords with a customer organization that also uses Ubuntu and finding it very hard to recommend Enpass due to the continuous crashes that have been ongoing since the beginning of the year.

I noticed that 1Password is moving into the Linux space.  I *really*, *really* like Enpass and desperately want to stay with it but the frustration caused by 10+ daily crashes is starting to add up...

Share this post


Link to post
Share on other sites

Hello, I'm sorry if I am hijacking this issue, but lately I have constant crashes for the Enpass app on an Ubuntu-based GNOME distro (Pop!_OS).

The crash always happens when I try to open one entry for an account or use the search box. If I wait long enough eventually the details for an account are rendered, but are glitching out (UI elements are radially moving outwards).

I'll try if I can get debug logs going and make video's of the visual glitches.

Share this post


Link to post
Share on other sites

@rubenJS not to worry, your post in perfectly on topic.  What versions of Enpass and Pop_OS are you running?

I found that Enpass 6.5.0.701 is the most stable for me on Ubuntu 20.04 (GNOME).  This is supposedly a beta version, which you can install by following these instructions.

Once you've done this, you can downgrade Enpass, as follows:

sudo apt update
apt-cache policy enpass				# shows all versions available from the repositories
sudo apt install enpass=6.5.0.701		# or whichever other version you'd like to try out
sudo apt-mark hold enpass			# prevent subsequent automatic upgrades by locking the installed version

The last line "holds" enpass to the installed version, so it doesn't get upgraded automatically later.  Use the same command with `unhold` if you'd like to try a newer version that will most hopefully fix things before too long...

  • Like 1

Share this post


Link to post
Share on other sites

In case this helps investigating the issue, I decided to run Enpass on the command line as follows:

/opt/enpass/Enpass > /tmp/enpass_log 2>&1 &

The logfile shows a large number of error messages that say: "QQmlComponent: Created graphical object was not placed in the graphics scene." (this happens as soon as Enpass is started, and some keep appearing later on).

I'm wondering if this (and my large number of crashes) could be due to the fact that I use multiple workspaces?  (note: workspaces are a standard GNOME feature that Enpass' developers may not be aware of.  It's essentially a grouping of windows and your monitor displays one of them at a time).  To move a window - such as Enpass' - to another workspace, right-click its titlebar and select "Move to Workspace Down".  You can then use Win+PgUp/PgDown to move between workspaces.  I typically choose the "Always on Visible Workspace" right-click option for Enpass, since I use it on multiple workspaces.

Here's a list of error messages that appear (multiple times) in stdout/stderr while Enpass is running.  The first one is by far the most frequent.

QQmlComponent: Created graphical object was not placed in the graphics scene.
Case insensitive sorting unsupported in the posix collation implementation
Numeric mode unsupported in the posix collation implementation
QObject::startTimer: Timers cannot have negative intervals

This is with Enpass 6.5.0.701 as it's the only post 6.4 version that's stable enough to consider using presently.

When Enpass crashes, it typically happens due to a SEGV (segmentation violation), which we could use to dump a memory image (core).  Let me know if I can assist analyzing such a core dump although it's obviously not something I could share since it might possibly include clear-text passwords etc.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...