Jump to content
Phylum

UWP Won't Connect to WebDAV; Win32 OK: Not able to connect to WebDAV. Please check Internet connectivity.

Recommended Posts

I setup Enpass on a new machine, both the Traditional Win32 version and the UWP via the Windows Store.

I successfully restored my data in the Win32 version but when doing the same in the UWP version, it fails with "Not able to connect to WebDAV.  Please check Internet connectivity."

It doesn't matter if I use valid or invalid credentials and it's not a matter of a bad WebDAV URL as

  • I copied the URL when setting up the Win32 version & pasted into the UWP version
  • I store the URL in Enpass so that when I have to setup another machine I can refer to it so I copied it from the Win32 app to be sure

Is this a real error or is there something else that's missing, like the UWP expects the SSL certificate to be installed etc.

Share this post


Link to post
Share on other sites
Guest Akash Vyas

Hey @Phylum

Sorry for the inconvenience. It'd be a great help if you can share a demo account of your WebDAV via a DM so that we can have a look at this issue. Also, please let me know if you're using a self-signed certificate.

Thanks for your cooperation.

Share this post


Link to post
Share on other sites

Hey @Akash Vyas

Yikes - I sincerely apologize for leaving this hanging for half a year!

I can confirm this this is still a problem today:

  1. I download & install Enpass on several Android devices, restore via WebDAV pointing it to the external URL and setup sync which works correctly:
    (a) on the same network as the WebDAV server,
    (b) via cellular data,
    (c) on an external WiFi connection
     
  2. I download & install the traditional Win32 version of Enpass, restore via WevDAV pointing it to the external URL and setup sync which works correctly:
    (a) on the same network as the WebDAV server
    (b) on an external connection be it WiFi or Ethernet
     
  3. I download & install the UWP version of Enpass, begin the restore process pointing it to the external URL and it fails with "Not able to connect to WebDAV.  Please check Internet connectivity" whether I'm doing this externally or from the same network as the WebDAV server.  And curiously, when I am doing this internally, it fails the same way when pointing it to the correct URL be it via hostname or IP address.
     

 

Initially I was using a self-signed certificate on the WebDAV server.  Later I moved using certificated from Let's Encrypt.  However the automated renewal process doesn't always work and I have not dedicated time to understanding the root cause to sort it out.  That said, the current Let's Encrypt certificate expired recently and I haven't renewed it.  Also, the certificates I'm using are not installed on the machine in question.

Is that a prerequisite for all UWP applications: to use valid certificates?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...