Jump to content
Enpass Discussion Forum

Multiple instances of enpass showing up in the dock on startup


Alex80
 Share

Recommended Posts

Hi,

since a few weeks I have this issue that enpass shows up multiple times in the dock on startup of my mac. It doesn't happen always, but often. Sometimes "only" 2 instances, sometimes many (see attached screenshot).

This happens before I start any other application.
I'm on macOS Monterey 12.3.1.
enpass 6.7.4 (938) from the app store
enpass is set to automatically run on startup in the settings.
edit: I don't know if this makes a difference, but I'm on a multi monitor setup.

It's not a critical error as I can simply click on one of the instances after the other and close it, and still everything works as expected. Still annoying though.

Bildschirmfoto 2022-04-11 um 09.15.51.png

Edited by Alex80
forgot to mention multi-monitor
Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

 @Alex80 and @Carsten1,

Our team is looking into this issue, meanwhile please share the following details so that we can able to resolve this issue together.

  1. Kindly check if you have multiple versions of Enpass installed in your device (Maybe both store and website builds).
  2. When multiple dock instances are listed, check into the activity monitor for the number of instances of Enpass that are running.
  3. Do you made any changes to the system/application like MacOS Upgrade or Enpass update?

#SI-2737

Link to comment
Share on other sites

Quote
  1. Kindly check if you have multiple versions of Enpass installed in your device (Maybe both store and website builds).
  2. When multiple dock instances are listed, check into the activity monitor for the number of instances of Enpass that are running.
  3. Do you made any changes to the system/application like MacOS Upgrade or Enpass update?

There's only one Enpass installed.

There's only one instance running but today it shows two app icons.

Not sure what kind of changes you referring to.

It didn't happen some days, but today it showed up with two icons.

 

 

Screenshot 2022-06-23 at 7.57.53 .png

Link to comment
Share on other sites

On 6/21/2022 at 12:30 PM, Gulshan Dogra said:

 @Alex80 and @Carsten1,

Our team is looking into this issue, meanwhile please share the following details so that we can able to resolve this issue together.

  1. Kindly check if you have multiple versions of Enpass installed in your device (Maybe both store and website builds).
  2. When multiple dock instances are listed, check into the activity monitor for the number of instances of Enpass that are running.
  3. Do you made any changes to the system/application like MacOS Upgrade or Enpass update?

#SI-2737

I wasn't able to check this earlier, but now.

  1. no, only the one from the app store.
  2. only one instance
  3. well, I kept my system up to date. That means macOS 12.4.

Today in the morning after starting the computer I had again two icons in the dock. At that moment I was still on Enpass 6.8.1 (1060) App Store. While reading the latest posts in this thread I updated to Enpass 6.8.2 (1082) from the app store.

Maybe it's fixed. I will let you know if not. ;)

Link to comment
Share on other sites

Posted (edited)

Well.. it happened again.
Now as mentioned before on macOS 12.4. and with Enpass 6.8.2 (1082) from the app store.

Edit: Activity Monitor showed only one instamce of Enpass running.

Bildschirmfoto 2022-06-29 um 09.04.23.png

Edited by Alex80
Link to comment
Share on other sites

7 hours ago, Discordant said:

When you hover over the Enpass icons in the dock, do all but one of them disappear?

No, they remain. When I click on one after the other it doens't open multiple windows/instances of Enpass. It seems that all of those icons are just bringing back the focus to the one single existing program window.

If I click on one Icon, then close the program window (with the red X in the top left corner) also one icon (the last one I clicked on) disappears.
So if that happens, I click on one of the icons then close the window and repeat that until all the icons are gone from the dock.

Link to comment
Share on other sites

Same here. It happened again.

When I click on one of the icons, the Enpass main window appears. Once I close that main window, that Icon disappears. When I click on the next Icon, the main window appears again. When I close it, that Icon disappears again. And so on until every Icon is away.

Screenshot 2022-07-01 at 7.40.24 .png

Link to comment
Share on other sites

  • 4 weeks later...

For me on a , Mac Mini M1 2020 with 16GB with MacOS 12.4, Enpass works great.

But on the Mac Mini M1 2020 8GB with MacOS 12.4 of my brother a similar issue (which was mentioned in this thread) showed up already the second time.

The issue

As soon he logged in, the Dock on the bottom fills up with multiple Enpass instances/icons:image.thumb.png.2f75963328005cdabf5a93d2890384b2.png

First attempts: To close all these

1. My fist idea was to close all Enpass instances via Terminal with the following command (without success):

killall Entpass

2. Then I looked into the activity-monitor for Enpass, but didn't found anything mentioning Enpass.

3. Afterwards I tried to find Enpass mentioning somewhere in the terminal (without success) with the command:

ps aux

Second attempt: To close all these

Because I wasn't able to find Enpass via terminal/activity-monitor, I decided to close all these instances/icon by hand.

Most of them disappeared already when you clicked on one of them (means, they didn't opened anything).

At the end only 4 instances/icons opened the window which asked for the master-password.

What was suspicious, these 4 instances/icons even stayed in the bar (as if you put them there for quick access) even after the window/instance was closed.

Afterwards when logged in with at least one master-password prompt/window, Enpass behaved normal like usual.

My guess: When tried to reproduce this

Could it be, that Enpass doesn't started on Startup and just the Firefox or Chrome plugin toggled these instances multiple times?
I just got the idea, because there isn't any clue about Enpass in the activity-monitor when so many instances/icons are running.

I tried to keep the Firefox instance open (one time without any windows, one time with two pages) and restart MacOS with remembering last session (opened apps).

Sadfully, without any result. I couldn't reprodurce/trigger the bug!

Now: Debug time

Enpass got installed the usual way once.

We could delete Enpass completely (and remove all installed extensions) and maybe with some luck solve the issue.

But this wouldn't help the Enpass community, so I think we will wait until the issue shows themself the next time, for further inspection.

And there is my question, what do you guys need for the next time?

- I'm developer and admin, so I can crawl every additional informations together when this happens again.
- Enpass logging is now enabled.

 

Edited by _Sascha_
spell corrections
Link to comment
Share on other sites

Hi @_Sascha_

I have duly noted your feedback and all the details have been forwarded to our concerned team for further investigation. I will update you on this as soon as I receive any updates from the team regarding the same.

In the meanwhile, your patience and support are highly appreciated.

#SI-2737

Link to comment
Share on other sites

  • 5 weeks later...
  • 2 weeks later...

I can report the same problem. I believe it always occurs on computer restart. I tried Force Quitting all of them, but they do not seem to go away. I killed Enpass and found then, that if clicked on each dock icon, they dissapeared. 

So there definitely is a problem that multiple users are seeing.

Link to comment
Share on other sites

On 8/23/2022 at 2:18 PM, Alex80 said:

I don't know if that information helps, but I migrated from a Intel MBP to a M1 MBA. I moved everything over with apples migration assistant and the issue is gone.

Rejoiced too soon. After the issue was gone for weeks, it's back now. :/

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...