Jump to content
Enpass Discussion Forum

Sync sometimes pushes old passwords on top of new ones


Hecsa
 Share

Recommended Posts

Hi everyone, I'm writing because I have a strange sync issue with the app.

First of all let me list my current setup to have some context:
I mostly use Apple devices (MacBook Pro M1, iPad and iPhone) and a Windows 11 PC.
Every device have the latest version of Enpass available, all setup with cloud sync on Google Drive.

Yesterday I noticed that some recently updated passwords went back to the old ones.
I suspect that one of my devices that I use less (maybe the iPad) pushed an old version of the password database to the cloud without checking if there was a newer version, and that led to new passwords being overwritten.
What's funny is that at some point I had my iPad with Enpass with an item, side-by-side with my iPhone with the same item and a different password, and this persisted even after forcing a sync on both devices.

At the moment I don't even know how many passwords were changed, since I'm discovering them one by one while trying to log into different websites, and for the time being i'm just asking those websites for a password reset.

Has this ever happened to someone that maybe found a solution? I also checked on my mobile devices if there was some background activity block, but found none. Could it be something relevant only on iOS devices? (I recently switched to iPhone, before I was using an Android device and I don't remember this ever happening there).

Thank you in advance!

Link to comment
Share on other sites

Hi @Hecsa,

Welcome to the Enpass Community Forum. 

Thank you for reporting the presence of this issue. Make sure all the devices have the latest Enpass versions and their date & time are the same across the devices. If both the details matched, try reinstalling the Enpass and restore the data on the device in question. Let me know if that helps.

Link to comment
Share on other sites

Hi @Manish Chokwal,

Thanks for answering!
I followed your suggestion and reinstalled the Enpass app from every device I own, and I took this occasion to switch my Cloud Sync from Google Drive to iCloud, copying every password from one Vault to the other.
Now it's only a matter of waiting and hoping this behavior doesn't happen again, and if so, I'll be sure to drop an update on this thread.

Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...