Jump to content
Gajender Singh

A new beta for Android is now available with bunch of new features, bug fixes and quality improvements

Recommended Posts

Hi @Vikram Dabas (You sent me a personal message, but the forum wouldn't allow me to respond, something about being blacklisted!).

(Also relevant to anyone having issues with doing a cloud-sync).

Going to Enpass Settings > Security, I disabled "Lock on Leave" and set the Autolock to "5 minutes". Now when I try to set up cloud-sync, the Enpass redirects me to Google/Microsoft/Etc as per usual, and on returning to the app it is still unlocked, allowing it to correctly finalise the syncing procedure. You can change your autolock settings back after this if you want.

Thanks for the suggestion!

Edit: Tagging those that have reported a similar issue @Sleeepy2 @Mateusz @mjeshurun @MikeR @JeffB

Edited by JERobertson
Tagging those with the issue.
  • Like 1

Share this post


Link to post
Share on other sites
6 hours ago, JERobertson said:

Hi @Vikram Dabas (You sent me a personal message, but the forum wouldn't allow me to respond, something about being blacklisted!).

(Also relevant to anyone having issues with doing a cloud-sync).

Going to Enpass Settings > Security, I disabled "Lock on Leave" and set the Autolock to "5 minutes". Now when I try to set up cloud-sync, the Enpass redirects me to Google/Microsoft/Etc as per usual, and on returning to the app it is still unlocked, allowing it to correctly finalise the syncing procedure. You can change your autolock settings back after this if you want.

Thanks for the suggestion!

Edit: Tagging those that have reported a similar issue @Sleeepy2 @Mateusz @mjeshurun @MikeR @JeffB

Thanks JERobertson,

Unfortunately, the solution of changing the Autolock setting is not working in my case, because I'm trying to restore my primary vault from the cloud and getting to Enpass settings is only available till after the primary vault is already set.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 11/29/2018 at 4:00 PM, JeffB said:

Well, today the Windows 10 app and Edge extension updated to V6 and it all went smoothly, including automatic update and conversion of the V5 database.

I am using Enpass V6 on my Android, but have not been able to sync with any of the services I tried (Dropbox and OneDrive). When trying OneDrive, it appears to go to the live.com site to try to sign in, but then seems to redirect to auth.enpass.io immediately and then returns back to the app immediately.

There was a note earlier that Enpass is aware of sync setup issues and they are being worked, so I hope this is resolved shortly.

Thanks, Jeff 

I have been using Enpass V6 on my Android V7.0 phone successfully since 11/30 and it has been working very well. Sync is smooth between PC and phone on OneDrive, my preferred cloud, but I am sure it will work with others since I tested earlier with Dropbox. 

I had reported slowness with signing in with Fingerprint security, but I have notice that it is the same when using the Master Password, so it is not the fingerprint processing that is slow, but is a general slowness with V6. I don't know if that can be improved but I hope so; it is at least 3 times longer than V5 (over 3 seconds on my phone). 

However, V6 features and functions are really appreciated, and I am confident the team will continue to improve the product that is greatly appreciated.

Thanks, Jeff

  • Thanks 1

Share this post


Link to post
Share on other sites
On 12/1/2018 at 4:37 PM, JERobertson said:

Hi @Vikram Dabas (You sent me a personal message, but the forum wouldn't allow me to respond, something about being blacklisted!).

(Also relevant to anyone having issues with doing a cloud-sync).

Going to Enpass Settings > Security, I disabled "Lock on Leave" and set the Autolock to "5 minutes". Now when I try to set up cloud-sync, the Enpass redirects me to Google/Microsoft/Etc as per usual, and on returning to the app it is still unlocked, allowing it to correctly finalise the syncing procedure. You can change your autolock settings back after this if you want.

Thanks for the suggestion!

Edit: Tagging those that have reported a similar issue @Sleeepy2 @Mateusz @mjeshurun @MikeR @JeffB

thanks this worked for me 

Share this post


Link to post
Share on other sites

If I can suggest an improvement to the password generation algorithm here. This is based on experience with some sites that do NOT allow special characters. It would be great to have a separator of NONE. And then if uppercase is selected, each word segment would have an initial capital (camel notation). Alternatively,  separator of DIGIT would put random digits as separators. This would make the process easier and there would be less post-generation edits on the password. 

Another observation: I have seen a few websites over the last few days that require the password to be between 8 and 20 characters. That is not the best implementation, but that is what I was experiencing.

Thanks, Jeff

Edited by JeffB

Share this post


Link to post
Share on other sites

I am using the Android Beta and Autofilling in the App Payback does not work. Enpass fills the Email in both the login name and password field.

It is this app:

https://play.google.com/store/apps/details?id=de.payback.client.android

Enpass Android version 6.0.0.98

 

And another suggestion:

Could you maybe rename the "Move to Trash" option just to "Delete" and make the Trash folder more visible?

Share this post


Link to post
Share on other sites
On 11/29/2018 at 11:58 PM, ubna said:
  • Redmi Note 4
  • Failed to encrypt the data with the generated key - toast error
  • Yes, I'm using my own build as i do not trust OEMs ROM and do not know what they are tracking from the device

@Vikram Dabas may I have an update on this please?

Edit:

@Anshu kumar @Gajender Singh May I get an update for the fingerprint issue on Android Pie?

Edited by ubna
No updates given by the Enpass team for FP Issue on Android Pie

Share this post


Link to post
Share on other sites

This is in the nature of an enhancement request, but I would consider it a minor bug. When I select one of the alphabet headings, the alphabet picker windows is displayed. When I select a letter, the current position is set to the letter heading. That works as expected. The problem is the position is set to the bottom of the screen (actually off the bottom of the screen. That section should really be at the top of the screen so that whole section of the alphabet is displayed. It is not a major issue, but would really polish up the feature.

Thanks, JeffB

Share this post


Link to post
Share on other sites

Hey @JeffB

6 hours ago, JeffB said:

This is in the nature of an enhancement request, but I would consider it a minor bug. When I select one of the alphabet headings, the alphabet picker windows is displayed. When I select a letter, the current position is set to the letter heading. That works as expected. The problem is the position is set to the bottom of the screen (actually off the bottom of the screen. That section should really be at the top of the screen so that whole section of the alphabet is displayed. It is not a major issue, but would really polish up the feature.

 

Thanks for the suggestion. We will consider it.

Cheers!
 

Share this post


Link to post
Share on other sites

Gentlemen,

I'm having trouble syncing to OneDrive. And yes, I tried without success: Enpass Settings > Security, I disabled "Lock on Leave" and set the Autolock to "5 minutes". 

Android to OneDrive: I am seeing that I "Last Synced 3 days ago." That means 13 December. As far as I know, it was working properly before that (but see below). Any ideas?

 

  • I'm on a Moto G5s Plus
  • Android 8.1
  • Enpass Android 6.0.0.98
  •  
  • My laptop is a Surface Go
  • Enpass on my Laptop: 5.6.19 (5548)
  • Laptop: Windows 10 1809 17763.194

Thanks in advance. I like your software!

Eric

Edited by Captain_Eric
Typos and clarity; found my answer to part of it.

Share this post


Link to post
Share on other sites

When an item is deleted, it is still visible in its parent tag.

  • Create an item "AAA" with tag "BBB"
  • From the left drawer select Tags > BBB
  • Now tap on item AAA entering "view-mode"
  • From the 3-dots "hamburger" menu select "Move to trash"
  • Item AAA is deleted but it's still visible in tag BBB

Share this post


Link to post
Share on other sites

When the trash is emptied, changes are not sync'ed across other devices.

  • Move an item to the trash
  • From the left drawer select Others > Trashed
  • Tap on the trash icon in the bottom-right corner
  • The trash is emptied but on the other devices the deleted item is still present (also after a forced resync)

Share this post


Link to post
Share on other sites

Hey @Captain_Eric

Sorry for the trouble you are going through.

13 hours ago, Captain_Eric said:

Android to OneDrive: I am seeing that I "Last Synced 3 days ago." That means 13 December. As far as I know, it was working properly before that (but see below). Any ideas?

I want to share that Last Synchronized and Last Attempt are two different timings. Last Synchronized is the time when the actual syncing of data took place last time and the file was successfully updated on the cloud, while the Last Attempt refers to the time when Enpass looked for any changes in data on cloud (and there might be chances that it didn't find anything to sync and is not matching with Last Synchronized). This is why you see different time stamps for both.

Further, I would like to share that since Enpass 6 is based on a new architecture, it will only sync with Enpass 6, and not with previous versions. So, to test the sync functionality, you’d need to install the Enpass 6 beta on your other devices as well. 

Hope this helps!

  • Like 1

Share this post


Link to post
Share on other sites

I have issues with syncing Enpass beta and Enpass 6 on PC.

I have two PC's with Enpass 6 and Android with Enpass 6 Beta. All of them are set to cloud sync via OneDrive

Both PC are syncing without issues. But it seems that default vault for beta is different - any changes done on PC are not updated on Android app. I've tried to disconnect from cloud and connect again - as a result the database was synced, but still different one than it is available on PC's.

When I go to the OneDrive apps folder I see three folders for Enpass:

1. "enpass" with some backup file inside

2. "enpass 1", where, according to last modification date, a file used on PC's is stored

3. "enpass beta" where, according to last modification date, a file used by Android app is stored".

What can I do to make all instances of Enpass use the same database?

And how to merge these two databases to not loose changes which were done in the meantime and not synced between PC's and Android?

  • Thanks 1

Share this post


Link to post
Share on other sites
7 minutes ago, kwieto said:

I have issues with syncing Enpass beta and Enpass 6 on PC.

I have two PC's with Enpass 6 and Android with Enpass 6 Beta. All of them are set to cloud sync via OneDrive

Both PC are syncing without issues. But it seems that default vault for beta is different - any changes done on PC are not updated on Android app. I've tried to disconnect from cloud and connect again - as a result the database was synced, but still different one than it is available on PC's.

When I go to the OneDrive apps folder I see three folders for Enpass:

1. "enpass" with some backup file inside

2. "enpass 1", where, according to last modification date, a file used on PC's is stored

3. "enpass beta" where, according to last modification date, a file used by Android app is stored".

What can I do to make all instances of Enpass use the same database?

And how to merge these two databases to not loose changes which were done in the meantime and not synced between PC's and Android?

@kwieto Well stated. I'll in a similar situation. Thanks for the post. Let's see what the answers bring.

Share this post


Link to post
Share on other sites
7 hours ago, Anshu kumar said:

Hey @Captain_Eric

Sorry for the trouble you are going through.

I want to share that Last Synchronized and Last Attempt are two different timings. Last Synchronized is the time when the actual syncing of data took place last time and the file was successfully updated on the cloud, while the Last Attempt refers to the time when Enpass looked for any changes in data on cloud (and there might be chances that it didn't find anything to sync and is not matching with Last Synchronized). This is why you see different time stamps for both.

Further, I would like to share that since Enpass 6 is based on a new architecture, it will only sync with Enpass 6, and not with previous versions. So, to test the sync functionality, you’d need to install the Enpass 6 beta on your other devices as well. 

Hope this helps!

Thanks @Anshu kumar I get it now.

Yes, you are right, I've moved my Android to Enpass 6 beta, but not my Laptop to  Enpass 6 beta, not yet anyway (I'm waiting a little bit for the issues to be solved and sorted out.) . 

Which brings me to:

1) Please see the recent post by @kwieto which raises some good questions about sync files in OneDrive

2) which Enpass should I get Traditional Windows or Windows 10 (from the store)? And dare I say, why pick one Windows version over the other? My sole concerns are longevity of the upgrade path and Extensions on Edge (which I believe both versions have now).

Again, thanks for your continued support and guidance. 

Share this post


Link to post
Share on other sites
7 minutes ago, Captain_Eric said:

My sole concerns are longevity of the upgrade path and Extensions on Edge (which I believe both versions have now).

If I may put my .3$, Enpass 6 (from app store) works better with Edge than Enpass 5.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, kwieto said:

If I may put my .3$, Enpass 6 (from app store) works better with Edge than Enpass 5.

@kwieto Thank you!

And, I hope you (and I) get the issues about syncing to OneDrive settled. (And I know this beta, so no worries.)

Share this post


Link to post
Share on other sites

Whenever I try to use Enpass to auto-fill a username and password in Brave mobile browser, I am given a list of only 5 or six logins (never the one I want, mostly ones I rarely use) that are linked to Brave. How do i link everything to brave browser? I don't even know how these 5 or six got linked.

  • Like 1

Share this post


Link to post
Share on other sites

 

Today I tried to connect the new Chrome extension to my MacOS Enpass 6 beta but it doesn't work: it opens a browser prompt to open Enpass app and the app is shown but then the main windows is shown and nothing happens. In the browser after a few seconds I get this message:

image.thumb.png.321a049039970522ed8453cfa90e9858.png

 

Any ideas what can be wrong?

Share this post


Link to post
Share on other sites

Hey @Piotrek 

Please share some more info so that we can help you better.

  • Which OSX and Enpass version are you using?
  • Which Firefox and Enpass extension version are you using?
  • Are you facing the same problem with other browsers too?

Thanks for your co-operation.

Share this post


Link to post
Share on other sites
18 hours ago, lcw731 said:

Whenever I try to use Enpass to auto-fill a username and password in Brave mobile browser, I am given a list of only 5 or six logins (never the one I want, mostly ones I rarely use) that are linked to Brave. How do i link everything to brave browser? I don't even know how these 5 or six got linked.

Currently, on Android, Enpass autofill is tested and working properly only with these browsers:

  • Chrome
  •  Edge
  • Firefox Focus
  • Opera 

However, I have noted down your suggestion to support autofill in the Brave browser.

Thanks!

  • Like 2

Share this post


Link to post
Share on other sites

Would like to see an "Unlock After" option of TWO minutes of inactivity.

One minute isn't enough time to get through login on mobile while switching between apps. If you get distracted for half a minute, you have to start over.

Five minutes is too long.

  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...