Jump to content
jankkm

macOS, webDAV: Self-signed certificate not working

Recommended Posts

I am using a local webdav server with a self signed certificate which I imported into my login Keychain and marked as trusted. In Enpass 5 that worked without a warning as expected but in Enpass 6 I get the red warning and I am only able to use the server if I disable the certificate check. Please fix this, thanks!

Share this post


Link to post
Share on other sites

@Anshu kumar This is very important! Please look into it!

It seems like visual issues get a much higher priority than security problems. I don't get it.

 

edit: It did some more testing and found out that it does work if I use a certificate that is signed by a ca that is marked as trusted in the keychain. This works for me now but I still think it should work with a self signed certificate that has been marked as trusted.

Edited by jankkm

Share this post


Link to post
Share on other sites

sorry for reuse this topic from last year, but I I have the same problem under macOS, too.

I have added my own root-certificate (public-key from my ca) into the MacOs-keychain and marked the certificate as trusted. But I still get the error-message from enpass, that the certificate isn't valid. Under iOS, enpass works fine without activating the switch to bypass the certificate-check. 

if I access the web-frontend of the webdav-server via https, the certificate is shown as valid. 

 

@jankkm, @Anshu kumar do you have any idea, why enpass think that the certificate isn't trustworthy?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×