Jump to content
jhf2442

Unable to open DB after login in arch linux

Recommended Posts

Hi,

database migrated from KeepassX, can access it with my passphrase.

When logging in, enpass is either started from start menu or when restoring previous session (tried both constellations). When I enter my passphrase, it is stated as wrong.

When killing enpass and restarting it, I can enter my passphrase and it unlocks the DB as expected

Any idea why the enpass that's started upon user login is not able to open the DB ?

 

Many thanks

 

Share this post


Link to post
Share on other sites

Hi @jhf2442

That's very strange! Please provide some more info for further investigation like  Enpass version, Cloud sync, Desktop environment along with Keyboard layout and default language for Enpass.

 

 

Share this post


Link to post
Share on other sites

Hey @Anshu kumar

I'm using enpass 5.3.0-1 on arch linux / KDE

cloud sync not configured - owncloud not working

keyboard layout is "de"

could the cause be that the root cause is that my enpass file is not located in a standard directory in my /home/$USER ? (BTW, what's the default location if any ?)

 

Many thanks for your support

 

Share this post


Link to post
Share on other sites

I have the same problem. Enpass is used on multiple linux machines but only on one this problem exists.

  • All Ubuntu with KDE (neon) 5.8.x
  • enpass 5.3 and 5.4.1 (same Problem)
  • "de" keyboard layout
  • sync with google drive

I deleted the Enpass directory and setup Enpass again for that user. Same result.

The passphrase is not working after login (autostart). I quit Enpass. After restart all works as expected.

I can't say what is different on this machine/user. The same data can be unlocked without problems on another machine with similar setup.

 

 

Share this post


Link to post
Share on other sites

I found in .xsession-errors:

QSqlDatabase: QSQLCIPHER driver not loaded
QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3

This does not happen when I restart Enpass.

 

On a machine where it works I have a process:

/opt/Enpass/bin/Enpass startWithTray

Where the problem exists:

/opt/Enpass/bin/Enpass -session 101.....

 

Maybe the autostart 'startWithTray' doesn't work for some reason and KDE restart Enpass without the wrapper script because of restoring the session, but then the environment for Enpass is missing and QSQLCIPHER driver is not found?!

Any idea how to fix that?

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...