Jump to content
Whitey

it seems your purposely deleted data from WebDAV

Recommended Posts

Hi all,

Since moving to the new major version, both my Macbook and iPhone complain about me "purposely deleting" data and refuse to sync.

I'm concerned I'll lose data on one or the other.

Both present the option to upload fresh, and in both cases they upload "successfully". Next sync on either device results in the same issue again, with the additional message of "No data found on WebDAV".

The WebDAV connection is correct (and had to be re-added, which was extremely annoying). 

On my ownCloud instance, the folder "Enpass" is there as usual. Inside is a file called sync_default.walletx (not modified in a week, I assume the sync file before the upgrade) and vault.enpassdbsync (modified within the last few minutes). Obviously permissions are correct, as each device can write this file, and reading has never been an issue pre-upgrade.

 

Please advise ASAP.

 

 

Share this post


Link to post
Share on other sites

Hey @Whitey,

We have fixed many issues related to WebDAV sync and an update will be rolled out soon. If possible, please share a demo account of your WebDAV server via Private Message, so that we can check it from our end.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hi Anshu,

Thanks for the reply. While I appreciate that new development can introduce new bugs, this is a pretty significant one - I face a possibility of data loss. This is beyond an inconvenience.

Please advise the ETA of a fix ASAP. This is unfortunately serious enough for me to move to another password manager if not resolved promptly.

I will not be able to provide a demo account for security reasons - the instance in question uses a private DNS entry and is heavily locked down. If you can advise me what specifics you require though (e.g. logs, versions, oc commands to run, etc), I'm happy to do so and provide results.

Thanks.

Share this post


Link to post
Share on other sites

Hi Anshu,

It's been 3 weeks, is there an update on this?

Please advise ASAP, as my data is now grossly inconsistent. Feel free to provide a beta release, happy to use one.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...