Jump to content
BrigoNortensson

Latest version breaks webdav syncing.

Recommended Posts

I've used the following folder for syncing through Enpass 5.x, and until recently in Enpass 6.x (for Mac).

URL/remote.php/webdav/Documents/Encrypted%20passwords/

In the past few days, it auto-updated to 6.0.5, I'm not sure when. And now it refuses to use that folder. If I just use URL/remote.php/webdav that will work, but I don't want this spamming up my root folder. Can this be fixed so that I can use a specific subfolder again? I use Nextcloud for things *other* than Enpass, after all, and this is just very messy. It's actually something that will make me stop using Enpass if it isn't fixed. That's why I stopped using 1Password, they had funny ideas about where I should be able to sync my vault. 

Share this post


Link to post
Share on other sites

I think it's because of the space used in your folders name. Somebody reported earlier there is a bug and Enpass can't handle the %20 in the current versions (although it was about the v 6.0.3, I think). Try it with a renamed folder like e.g.:

URL/remote.php/webdav/Documents/Encrypted_passwords/

Share this post


Link to post
Share on other sites

I can't currently change the folder name. It would be strange if whatever library they were using to handle http didn't know how to handle uri-encoded urls. 

Thank you for the suggestion. I appreciate the help.

Share this post


Link to post
Share on other sites

I'm not suffering from this bug myself, but as I said somebody else reported such an issue:

 

If you want, I could test if this issue still remains with 6.0.5 later today or tomorrow.

Share this post


Link to post
Share on other sites

@BrigoNortensson 

I finally can confirm there is a bug and it's impossible to use a folder, that contains a space in it's name. As a temporarily workaround you could use folder sync instead, if your folder .../Encrypted passwords/ is somehow synced on your Mac. 

Share this post


Link to post
Share on other sites

Finally got 6.0.6 this morning, still broken.

This is unacceptable. The only feature that Enpass got right that no other password manager did was Webdav syncing. If 1Password had this, I would never have switched to Enpass.

I've been without syncing on my work machine for a month now. Thankfully I still have 5.x at home... but I have to wait until I'm off work to create any new internet accounts which I don't have access to from my work machine. What gives?

  • Sad 1

Share this post


Link to post
Share on other sites
On 3/5/2019 at 4:00 PM, BrigoNortensson said:

Finally got 6.0.6 this morning, still broken.

And support wrote me in February:

" Me: “Enpass can no longer handle directories that contain a space.”

Support: This issue has been fixed and the update will be available in the next update. I will like to have your feedback after the update.


Thanks for your co-operation."

They have never tested it :(

 

  • Sad 1

Share this post


Link to post
Share on other sites
On 3/5/2019 at 4:00 PM, BrigoNortensson said:

[...] The only feature that Enpass got right that no other password manager did was Webdav syncing. If 1Password had this, I would never have switched to Enpass. [...]

Same for me. For now I'm checking the new bug discussions in the forum but I'm not willing waiting for Enpass any longer. I have switched to Safeincloud using Webdav there. It has not as many features but the ones it has are stable....

  • Like 1

Share this post


Link to post
Share on other sites

Thanks @kingshill, I'll have a look at safeincloud too.

My thread has been ignored for 2 months now, even though there was a promise of a fix "by the end of next week" in January.

 

Share this post


Link to post
Share on other sites

@enpass @Vinod Kumar @Anshu kumar @anshul

This is what happens when you ignore your customer base and refuse to provide updates. They go to a competitor. Please learn from that. I've spent years recommending Enpass to friends and family, now it appears I'll need to find a new solution and start recommending this.

Share this post


Link to post
Share on other sites

Hey @Whitey,

We are really sorry that you have to wait for a long time.

An update of Enpass in iOS platform has already been submitted to the App Store and it's in the queue and hopefully will be available in the next week.  I request you to please bear a few more days.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hi @Anshu kumar.

Glad you're alive! I suspected you had been eaten by a bear.

I can't think of any other reason to not provide any update whatsoever in TWO MONTHS.

I'll wait until Friday, if not I'll be moving to SafeInCloud, which appears to be a nicer solution that works well with webdav.

Share this post


Link to post
Share on other sites

Hey @Whitey 

Sorry for the inconvenience caused to you.

We have already rolled out the update on the iOS version of Enpass. Please update the Enpass app and share your findings.

Thanks!

Share this post


Link to post
Share on other sites

6.0.7 was waiting for me on my work computer (Macos) this morning.

Fails the same way as 6.0.6 and 6.0.5. 

Thankfully, I haven't upgraded to 6.x on my home computers... they're still usable. But I'm stuck in a position where my work computer only has the old passwords, and none of the new. And if I ever forget and add an account on the work computer, I'm going to have a hell of a time reconciling the two (as yet, the work computer's copy of the vault is some old snapshot).

Please fix this. I cannot wait forever. The only thing preventing me from switching is that I've yet to find another password manager that worked as well as Enpass 5.x for this particular feature. 

Share this post


Link to post
Share on other sites

Hey @BrigoNortensson,

We are really sorry for the trouble you are going through.

We have checked this issue with the different WebDAV accounts and got some feedback from the customer that its working fine. It would be a great help if you can share the demo account of your WebDAV via PM so that we can check where the problem could be and try to fix asap.

Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...