Jump to content
TonyBurn

enpass app attaches to eGPU

Recommended Posts

I'm using a macbook pro 2017 15" and have an eGPU configuration when I am sat at my desk, the GPU is a 580RX.  MacOS provides an option to hot unplug the eGPU, however the newly updated enpass app is for some reason making use of my external GPU instead of the integrated GPU, and fails to quit successfully.  Once unplugged I need to kill enpass and open it up again.

Only applications that need to high amount of GPU resources would normally attach to the eGPU, how can enpass app be configured to prevent this?

  • Confused 1

Share this post


Link to post
Share on other sites

Forgot to add, this had never been an issue prior to the v6 upgrade.  What changed in the macos app between v5 and v6 which could influence this behavior?  Is v6 using electron and v5  not?

Share this post


Link to post
Share on other sites

Interesting. On my Surface Book 2 with dGPU (detachable), Enpass starts on the internal GPU. But Windows does that by default. Is there an option in MacOS to change the default GPU on a per-app basis too?

Share this post


Link to post
Share on other sites
On 2/8/2019 at 9:11 PM, Damasta said:

Interesting. On my Surface Book 2 with dGPU (detachable), Enpass starts on the internal GPU. But Windows does that by default. Is there an option in MacOS to change the default GPU on a per-app basis too?

Unfortunately I don't think there is.  I'd like to understand what changed with v6 which possibly made enpass gfx hungry and it that can be reverted?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×