Hi @Dave 003 Sorry for the unpleasant experience. I would like to let you know Enpass extension communicate to Enpass over localhost address. One of the possible reason might be that you are using Proxy settings for local addresses.To resolve the issue please follow the steps given below:   Go to System Preferences ➝ Network ➝ Ethernet/ WiFi/ Other Network ➝ Advance ➝  Proxies ➝ Web Proxy (HTTP) and in the Bypass proxy settings for local Host & Domains box.