Jump to content

Tamaskan

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Tamaskan

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello, since Qt 5.7, QGtkStyle is removed, so Qt applications don't look native anymore on the GNOME desktop. To fix this, I installed adwaita-qt5, which is a port of the default Gtk theme to Qt. I globally set QT_STYLE_OVERRIDE=adwaita so all my Qt applications use the new theme. Actually, Enpass isn't affected by this at all, as is uses bundled Qt 5.6 and uses QGtkStyle on GNOME per default. But settings QT_STYLE_OVERRIDE=adwaita causes Enpass to try to load the Adwaita theme, which fails, and then it falls back to an Windows 95-like theme which is really ugly. The solution is to modify runenpass.sh, just add export QT_STYLE_OVERRIDE="" somewhere before the exec statement. Enpass uses QGtkStyle again. I would be pleased if this change would merged upstream :-)
  2. Hello, the Linux installer contains unnecessary .DS_Store files, which are created by the Finder on OS X to store icon position etc. You can find them using: find ~/.local -name ".DS_Store" I think you can't prevent Finder to create these files, but you could exclude those files from your VCS so they can't accidently be commited again.
  3. You need to log out/log in again (or reboot) before changes in global environment variables take effect. If you edit runenpass.sh, the changes take effect the next time you run Enpass.
  4. I would suggest adding a checkbox in the settings to enable/disable HiDPI support. This could also be asked in the first setup dialog. Or add this workaround to the FAQ.
  5. @Vinod Kumar: Fedora 23 also comes with Qt 5.6. When I delete the bundled Qt libraries from lib/, Enpass uses Fedora's Qt, but the bug is still present. Other Qt apps I use are not affected. Did you have written any specific code in Enpass handling HiDPI support? I'm very curious if this is an Qt bug, which should be reported to the Qt devs and fixed upstream, as other users here seem to have had the same problem with other applications.
  6. Hello community, after updating to 5.2, the main window and all dialogs were really large, everything was scaled up. I assumed that somehow HiDPI scaling was enabled, but my laptop monitor is 1920x1080 with 96 DPI. So I added export QT_AUTO_SCREEN_SCALE_FACTOR=0 to runenpass.sh to force Qt to disable HiDPI support, and the problem was resolved. I don't have this problem with other Qt 5 applications and on another computer with the same screen resolution Enpass 5.2 is running fine without the workaround. Both computers are running Fedora 23 with GNOME 3.18. Did you guys changed something regarding HiDPI in the latest release? I'm really confused why this bug doesn't occur on my other computer. The only differences are that the affected machine is a laptop, while the other one is a desktop computer using an DVI-connected external monitor. The laptop has Intel graphics, the desktop AMD graphics with the free drivers.
×
×
  • Create New...