Jump to content
Enpass Discussion Forum

Linux Dropbox not opening browser to authenticate


GuyR
 Share

Recommended Posts

Before posting, I searched for similar discussions and found several.  For example, here's one:

I already have Enpass running in Windows, Android and other Linux installations.  So I'm not sure why this one is different.  Well, the version is newer: Ubuntu MATE 23.10, and is running in a VirtualBox VM, so maybe that has something to do with it.

At any rate, I followed instructions to install, and that went without error.  I'm able to start the app, but when I select Dropbox as my vault, it tells me that is opening Dropbox in a browser to authenticate, but the browser is never opened.  I found a suggestion to try running Enpass as root user, and that actually worked; it opened a browser and went to the Dropbox site.

Well, obviously, I don't want to use the root user to access Enpass, so I copied the link from the root browser, then exited root.  I then opened up my default browser (Firefox), and restarted Enpass.  When I told it to use Dropbox for my vault, it again sat there spinning.  But I jumped in Firefox and pasted the link I had copied from root.  It authenticated me, and then passed the authentication back to Enpass.  This actually worked! :-O  Enpass finally asked me for my Dropbox password; for those who find this post by search, at this point you must enter your *master* password, not your normal Dropbox password.

Hopefully this helps somebody.  Let me know if anyone would like to try to debug this.  I have the VM backed up, so I can easily recreate the problem scenario.

Edited by GuyR
  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...