Jump to content
Enpass Discussion Forum


  • Posts

  • Joined

  • Last visited

Posts posted by insigma

  1. On 11/28/2020 at 5:10 PM, Byb said:


    Sorry to disturb, it seems I have a very similar problem after migrating my Owncloud server.

    What do you mean by "an option called trusted-proxies" ? Is it an Apache option ? A Nextcloud option ? An Enpass option ? Where can I edit this please ? Thanks

    This is a config option in Nextcloud (and newer version of Owncloud i think). Just add


    'trusted_proxies' => '<YOUR PROXY IP>',

    to the config.php of your Nextcloud config if you use a reverse proxy in front. This config.php should be in the config directory of your Nextcloud installation.

  2. 2 hours ago, Kashish said:


    Make sure that the URL you are using in Enpass is in the required format https://{host}/{path}/remote.php/dav/files/{username}  

    You could PM me the demo account credentials if you still face an error with the above configuration. Also, let us know the Enpass version and the OS you are using.

    Hi @Kashish

    that wasn't the problem. The problem was a option called "trusted_proxies". After adding everything worked perfectly. Tested with Windows, Linux (Manjaro), OSX and IOS as well as IPadOS.


    • Thanks 1
  3. Hello,

    I'm not sure if that belongs to the topic, but I'm currently migrating from Owncloud 10.5 to Nextcloud 19.0.2., and have the same problem with Enpass. The username and password are definitely correct, and I still get a 401.

    However, I have found that if I bypass the HAProxy connected in front of it, the synchronization works immediately. The HAProxy is in http mode and has so far run with the Owncloud without any problems.

    I'm still looking for the problem, but I'm afraid that it could be an interaction with the Nextcloud, since I'm now on the standard configuration of the HAProxy and really can't do much more.

  • Create New...