Jump to content
Enpass Discussion Forum

Doesn't write .CSV file on export


Recommended Posts

I have encountered what looks like *two* bugs in the .csv export function on macOS.

I am trying to write a .csv file to the top-level directory of a mounted encrypted sparse image. That is, I have a 500MB file on my desktop, which when I click on it and feed macOS a password, gets mounted as /Volumes/passwords.

I select Enpass's Export menu item, choose CSV, and browse to /Volumes/passwords. Then I click the export box, enter my master password and Enpass says it has successfully exported the file. Except it hasn't. It doesn't appear in the directory, or, as far as I can tell using "find -name", anywhere.

Looking at the copy of in.sinew.Enpass.plist in the container Library/Preferences with "plutil -p", I saw that it tried to write to "file:///Volumes/". That's the first bug. It is stripping the last component of the path and trying to write to the directory above the one it should be.

So I got a bit cunning and created the directory "/Volumes/passwords/dummy" (also proving that I could write to the mounted volume) and tried again. This time the .plist file said "file:///Volumes/passwords/", confirming my analysis of the first bug. But it still didn't write the file anywhere I could find, so that's the second bug.

I am using Enpass 6.1.2 downloaded from the web site, on macOS 10.14.6. This worked using Enpass 5.5.7 on the same (current) version of macOS on another machine, writing to the same sparse bundle (which I later copied to the machine with 6.1.2). Indeed, what I was actually trying to do was dump the vaults on the two machines and then use "sort" and "diff" to check one really was a mirror of the other as they were supposed to be.

Edited by lemonjuice
Link to comment
Share on other sites

  • 2 weeks later...

It's now been two working weeks since I reported this bug here, with no response from Sinew.

However, I can report on a successful workaround. Exporting to a .txt file does work. The format is fairly obvious, and I was able to write a small program which massaged it into the kind of text file with delimiters that Unix utilities like. From there, I used the sort and diff utilities to verify both my vaults held the same data (even though one was from Enpass 5 and the other from Enpass 6).

I would be able to fairly easily create a .csv file from there for export to another password manager, which alleviates the other concern I had about these bugs.

However, the average user could not do this.

Edited by lemonjuice
clarify I didn't implement a CSV converter
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy