Jump to content
Enpass Discussion Forum

iCloud renew authorisation fails when using another browser than Edge


Recommended Posts


I'm using Enpass on Windows 10 (latest updates), my default browser is Vivaldi (with the Enpass extension installed).

From time to time the iCloud authorisation runs out (due to time limitation?) and has to be renewed.

This doesn't work for me, when I just do the  un-sync / re-sync thing. The app gets stuck with a loading animation.

Then I remembered that the sync button is supposed to open a website in the default browser. I switched from Vivaldi back to Edge and it worked. After that I can switch back and everything's fine.

Is this a bug?

Link to comment
Share on other sites

  • 2 months later...

Same here, except I don't have Edge on my work PC so for me, iCloud now doesn't work at all.


What happens is it opens to apple-cloudkit.com, that asks me to log in, which I do (including 2 factor auth), then it asks for permission to open enPass - which I allow - and then the webpage and enPass both just sit there doing nothing. Tried using Chrome and IE. Incidentally this works fine on my Linux machine.

Edited by Netizensmith
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...