Jump to content
Enpass Discussion Forum

Enpass stopped syncing with Nextcloud


mattias
 Share

Recommended Posts

Since I updated to Nextcloud 18 Enpass fails to sync, this is both on my iOS device and my desktop (Mac/Win10/Ubuntu 19.10).

The error I get is this:
"This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client."

Feels like a config issue, something has changed on the Nextcloud side... but please help!

Link to comment
Share on other sites

No I had the url under my main vault and the sync just spun and spun and then gave an error saying that it couldn't sync.
The "error" is then I tase the enpass sync url into a web browser.

I tried to use another client to connect to webdav and it isn't working.

Thanks for the link I will dig into it!

Edited by mattias
Link to comment
Share on other sites

ok, again the message you recieved in the browser is expected when using a browser to that url.

But since its there the dav seems running.

Backup enpass vaults and then remove data and set up sync again.

If you're using external storage in nextcloud for enpass id then start checking those.

 

Check the Log within nextcloud, esp. if youre using external storage.

 

here's how you can investiage apache-logs, if you're not familar with it already.

sudo apt install multitail -y && sudo multitail /var/log/apache2/access.log

or grep your IP if you have much traffic to it

egrep "192.168.1.123" /var/log/apache2/access.log

You should see som PROPFIND and GET from your client reaching the Enpass-data and at least one response code if 200. redirects like 300 and forbidden 400 is fine.

You should not see response codes of 500.

 

Link to comment
Share on other sites

@Ivarson thank you, yesterday I had some more time to test what was not working, from macOS or Win10 it was not working but from Ubuntu 19.10 it was working just fine.

Kinda surprised I have to say, I did check the logs and saw PROFIND and GET, like this:
 

172.18.0.5 - mattias [15/Mar/2020:12:26:14 +0100] "PROPFIND /remote.php/dav/files/mattias/ HTTP/1.1" 207 380 "-" "Mozilla/5.0 (Macintosh) mirall/2.6.1stable (build 20191105) (Nextcloud)"
172.18.0.5 - mattias [15/Mar/2020:12:26:16 +0100] "GET /ocs/v2.php/core/navigation/apps?absolute=true&format=json HTTP/1.1" 200 529 "-" "Mozilla/5.0 (Macintosh) mirall/2.6.1stable (build 20191105) (Nextcloud)"
172.18.0.5 - mattias [15/Mar/2020:12:26:19 +0100] "PROPFIND /remote.php/dav/files/mattias/ HTTP/1.1" 207 380 "-" "Mozilla/5.0 (Macintosh) mirall/2.6.1stable (build 20191105) (Nextcloud)"
172.18.0.5 - mattias [15/Mar/2020:12:26:21 +0100] "GET /ocs/v2.php/core/navigation/apps?absolute=true&format=json HTTP/1.1" 200 529 "-" "Mozilla/5.0 (Macintosh) mirall/2.6.1stable (build 20191105) (Nextcloud)"
172.18.0.5 - mattias [15/Mar/2020:12:26:21 +0100] "PROPFIND /remote.php/dav/files/mattias/ HTTP/1.1" 207 380 "-" "Mozilla/5.0 (Windows) mirall/2.6.4stable-Win64 (build 20200303) (Nextcloud)"
172.18.0.5 - mattias [15/Mar/2020:12:26:24 +0100] "PROPFIND /remote.php/dav/files/mattias/ HTTP/1.1" 207 380 "-" "Mozilla/5.0 (Macintosh) mirall/2.6.1stable (build 20191105) (Nextcloud)"

I should say that I am running Nextcloud via an Docker image, to be exact Linuxserver.io's image.

Link to comment
Share on other sites

  • 1 month later...
On 3/17/2020 at 7:30 AM, Pratyush Sharma said:

Hi @mattias,

Sorry for the trouble you are going through.

The error message you are getting shows up when either the Nextcloud WebDAV interface is off(in Nextcloud's settings) or the URL you've entered in Enpass is incorrect.

No problems any more, Nextcloud was the bad guy here. That is taken care off.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...