Jump to content
Programie

Sqlcipher driver not found

Recommended Posts

I'm using Enpass on Ubuntu 17.04 with KDE. Enpass is automatically started on startup using the KDE autostart.

On every boot, Enpass shows me an error "Sqlcipher driver not found". The same issue happens whenever I start Enpass from Latte Dock. But it works when I start it from the KDE application menu.

In case of the KDE autostart, Enpass is started using "/opt/Enpass/bin/runenpass.sh startWithTray". If I execute that directly, it works. But why doesn't it work when started on login?

is that an issue with Enpass or am I just doing something wrong?

 

Details:

Description:    Sqlcipher driver not found.
Database Path:    /home/programie/Documents/Enpass/walletx.db
Drive Type:    /dev/sda5
Accessible    True
Writable:    True
Keyboard Layout:    English
Enpass / Operating System version:    5.5.6 / Ubuntu 17.04

Edited by Programie

Share this post


Link to post
Share on other sites
Guest Akash Vyas

Hey @Programie

This is a known behavior when you set Enpass to run on system startup instead of enabling it from Enpass Settings. However, I've opened an improvement ticket and notified the dev team about it.

Cheers!

Share this post


Link to post
Share on other sites
6 hours ago, Akash Vyas said:

This is a known behavior when you set Enpass to run on system startup instead of enabling it from Enpass Settings.

That's exactly what I did.

I just removed the entry from the KDE Autostart and re-enabled it in Enpass settings again. However Enpass just created exactly the same entry with the same command (/opt/Enpass/bin/runenpass.sh startWithTray).

Share this post


Link to post
Share on other sites

I had the same issue with XFCE. It would try to relaunch it at startup and fail with that error. The cause of it is that the Enpass and EnpassHelper programs register themselves with the session manager, which caused the DE to try and relaunch them. The easiest way I've found of fixing it is to add this line to the runenpass.sh script:

export SESSION_MANAGER=

Add it just before the 'LD_LIBRARY_PATH' line. This prevents Enpass from finding the session manager, and allows my manually added autostart to work.

Regards
elFarto

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...