Jump to content
Sign in to follow this  
janodin

Setting up secondary vault in Enpass is failing auth flow

Recommended Posts

I just set up the rpm installation of enpass on a new install of Fedora 32. I use two different vaults in two Google accounts synced with Google Drive. Setting up the primary vault to sync worked great, clicked the xdg-open dialog and enpass received the auth validation token properly. I'm now setting up the secondary vault and it's failing on the xdg-open redirect. Even though enpass is running at the time waiting for the auth. I've tried both firefox and chrome and they both look like they are not properly submitting the URL to enpass through xdg-open. 

I read a few threads here and tried various things like rebooting or  updating desktop and mime databases. Executing xdg-open with an enpassauth:// scheme in a terminal actually is caught by enpass and it displays an error obviously since I don't have the proper information in the url path. Going to boot back into linux and try a couple other things, I'll update if I end up fixing it. I just think it's strange that it was working fine when I added the first vault and now it's weirdly broken trying to add another one.

 

Well that was weird, it seems to be working now. I guess rebooting twice is the answer.

Edited by janodin
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...