Jump to content
Enpass Discussion Forum

iOS: Password saved in cache?

Recommended Posts

Since month, I'm using "Bitwarden" and here I have the problem that passwords seem to be saved in browser cache or elsewhere. Now I'm trying "Enpass" and it looks great so far, but it seems that I have the same problem here.

I'm using "Enpass" on Windows 10 with cloud sync enabled via OneDrive. Safe is synced to my iPhone with iOS 14.3 installed. If I create or change an entry in the desktop app it is synced to the iOS app. So I have a login saved in "Enpass" for a website. When logging in to the website in Firefox on iOS everything works great, and I'm able to login.

For testing, I changed the password of that entry to a wrong password in the desktop app. The changed password is synced to my iPhone and is visible in iOS app. But when trying to log in to the specified website using autofill login is successful. And this is strange... Because I definitely have a wrong password in "Enpass" for that entry. When manually copying the password from the iOS app into the password field login fails. So it is the same as it is in "Bitwarden".

Now I created an account in "1Password" and tried the same. Here everything works like it should work. First I log in to the website with the right password saved in "1Password" with the help of autofill on my iPhone. Now I changed the password in the desktop app into a wrong password and tried logging in to the website with autofill. Login fails.

So for me, it seems like the password filled in with autofill from "Enpass" is saved in the browser cache or elsewhere, so that changing a password doesn't overwrite the cached password and the "old" password is used when trying to log in with the "new" password although the "new" password is visible in the desktop and the iOS app.

What could be the problem? What can I do to fix this behavior? Actually this is the showstopper for me switching with all my passwords to "Enpass".

Edited by DenalB
Link to comment
Share on other sites

I just found out that this is not an issue with Firefox. I tried Safari browser and here the problem also exists. I never tried login in to Safari with the help of „Enpass“. But autofill is not using password saved in „Enpass“ right now. As you remember in „Enpass“ a wrong password is saved and login is succesfull.

Link to comment
Share on other sites

Hi @Garima Singh

I just tried logging into 3 websites with the help of the iOS app. After successfully login I changed passwords in Windows 10 desktop app. With the new passwords I was able to login to the websites in the desktop browser. I opened iOS app and the safe was synced. Now tried in iOS Firefox to login to these 3 websites and... It works! I'm just a little confused because 2 days ago I spent some time to argue with this bug. But now everything works like it should work. :/

I don't know what was wrong but actually it works. Sorry for reporting!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...