Jump to content
Enpass Discussion Forum

Sync failed with Nextcloud 13


plinss
 Share

Recommended Posts

Running Enpass v5.6.3 (139) on macOS desktop and v5.5.6 on iOS. I have been successfully syncing to a Nextcloud instance for quite some time.

I just upgraded the Nextcloud instance to V13 (from V12) and Enpass sync no longer works. No useful error messages and nothing relevant in the Nextcloud logs, the Nginx access log lists:

"PROPFIND /remote.php/webdav/ HTTP/1.1" 207 5488

"PROPFIND /remote.php/webdav/Enpass/ HTTP/1.1" 207 848

and nothing else related to Enpass.

All other Nextcloud functions, including WebDAV file sync with the Nextcloud client are working normally.

Link to comment
Share on other sites

Hi Akash, further testing shows that the problem appears to be related to the new end-to-end encryption module.

When I disable end-to-end encryption the sync starts working again, re-enabling the module causes sync to start failing with the error "Error getting file. Please try after sometime (Error code: -119)" on iOS and "There went something wrong while synchronizing. (Error code: -116)" on macOS desktop.

Note that I haven't actually enabled end-to-end encryption on any folders, just turning the end-to-end module on causes the problem.

At this point I have end-to-end turned off on my instance, but I can turn it on and create a test account if you need one, but please give me a time window when you'd be able to take a look so I don't have to keep it on (and break my syncing) for too long.

Link to comment
Share on other sites

  • 2 weeks later...
Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...