Jump to content
Enpass Discussion Forum

Can't Create new Vault - nor restore


Recommended Posts

Using Linux Mint 19 - and Latest version of enpass. 

Everything was working fine until I did a sync on my primary vault (maybe a stupid move). Sync failed and error. Data wouldn't show up, but counters would show how much data there was in category. I exited and password wouldn't work any longer. I have purged - uninstalled - timeshifted reinstalled every time and tried to use password on a backup - no workie, enpass will not create a new user primary vault either. All files seem to be there, but no database. It is remembering too much and I don't know where to clean out the old stuff. I know it remembering because I had moved my vault to a new location and it is using that and not the default location /Documents/enpass. Anyone know where it is keeping this data, don't want to get out the shotgun as that is too messy.

Thanks Jes

Link to comment
Share on other sites

Guest Vikram Dabas


Sorry to hear that. Please share the following information so that I can assist you better:

  • Is the new data location set to a Remote disk or locally on the system?
  • Does the Enpass app has required permissions, i.e., Both Read and Write to the new data location?
  • Do the Documents still contain any Enpass folder? If yes, what are the files saved in it?
  • Are you able to access your data on any of your devices?
Link to comment
Share on other sites

Thanks for responding. Didn't really believe anyone would. Sorry. 

Data was located on a local disk sdc1, I have sense moved it to a network share on a freenas system. Actually moved it to the share so I could see what a share string looked like. I have been trying to get Emby to reference a share and had no clue, as to what the share string should look like. I'm a Linux newbee. Spent many years as a developer/programmer on windows systems. I tried your program see if it would give me a string to look at. It did and I was pleased.

This was not a security issue, as I stated it was working perfectly, until I did the sync and got the error. Also I deleted the Enpass folder copied it in again deleted it again, cleaned it in every way you can imagine. Every file and folder was there except the file vault.enpassdb when it was failing. 

I have cleared the problem. I used the shotgun! I showed hidden files and deleted everything with any reference to enpass, except the file used to do the install. I don't know which file had the error and don't really care at this point.

I am now able to create a new vault and will restore from a previous backup. 

Again Thank you soo much for responding.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...