Jump to content
Enpass Discussion Forum

100 Watt Walrus

Members
  • Posts

    231
  • Joined

  • Last visited

  • Days Won

    22

Posts posted by 100 Watt Walrus

  1. A couple new bugs for you, both in the UI for creating/editing an item:

    1) CMD+S doesn't save (you have to use the SAVE button)

    2) In Mulitline fields you've created yourself (i.e., in your own custom template), the text doesn't wrap in the Edit view, so if you type a line longer than the width of the field, you can't see what you're typing:

             1037823559_Multilinetextwrapbroken01-EDITview.png.8020ca3a5d1356355fb6d2ca788e8250.png

     

    It does textwrap just fine when viewing the item:

             1531189212_Multilinetextwrapbroken02-DISPLAYview.png.42aea0155c533c9b207498256d9df973.png

  2. 3 hours ago, fermati said:

    The following is related to the web browser extension usage.

    On my machine Enpass6beta is set to launch at startup. After entering the master password I hide the main window by option-clicking on the desktop. What seems to be a little odd is that every time I use the extension in Firefox to fill in a logging, the main window comes back to the front. Same thing with Safari. If it is intentional I am not sure it should be kept because every time the main window has to be hidden back to the background.

    Why keep the main window open at all? No need to OPT+click the desktop (do you know you can CMD+H to hide the foreground app?). You can just click the red (X) in the main window. Enpass is still in the Menu Bar and in your browsers if the main window isn't running. You can also hide it in the Dock (no need for it to be there since you can get to Enpass from the Menu Bar:

    Settings > General > Hide dock icon when main window is closed

     

  3. On 9/7/2018 at 4:46 PM, fermati said:

    Open it in Preview then save it as a png (icns cannot be opened in Photoshop). That png was then opened in Photoshop to be sized at 200px x 200px, at 72 dpi as recommended by Anshu kumar.

    FYI, you could have saved yourself a step and just resized them in Preview. :)

    Can confirm this issue though. Screenshots below from me of custom icons, made per instructions upthread.

     

    1173574932_jaggedcustomicon.png.cfc7d0d33425bfc566e267c3fb553be7.png

  4. Great news, Anshu Kumar! Thanks. My eye went right past the Multiline option. I'm not sure I would have known what that meant had I noticed it. Maybe for clarity call it Text (Multi-Line) instead. Also, in the Field Type menu, the list should be in alphabetical order. Right now they're a jumble.

    A question: Does the vault save customizations too, like custom templates? Or do those have to be recreated on each computer?

  5. Back yet again with a question: Just made a new vault in Dropbox — and it to Dropbox/Apps/Empass Beta.

    This is a problem because folders inside /Apps/ on Dropbox cannot be shared. This was a vault I'm setting up for my elderly dad, so I can help him maintain his passwords.

    He has a hard enough time understanding the cloud, and barely uses Dropbox as it is, so I'd rather he not have to download and learn another cloud service.

    Suggestions? Will production version of Enpass 6 allow users to chose the directories to which their vaults are saved in the cloud? (I'm getting some deja vu here, forgive me if this has been asked and answered.)

  6. New suggestion: In the ITEM layout, the Password label (and in the Bank template, the Transaction Password) are awkwardly placed, in that they don't line up next to the field they're labeling. Instead then line up next to the password strength meter. I realize this is because the label is in the middle of all three pieces of password UI (field, strength, "generate" button). But it's really confusing and unintuitive, and it's inconsistent: The Notes label is not halfway down the Notes field.

    The field name should always be next to the field, not below it. See attached image.

    pw label alignment.png

  7. I'm back again with another request:

    Please add the ability to create additional "notes" fields in custom templates.

    (I tried adding Text fields, but they're one line of text only, and therefore are useless for different categories of notes.)

    Use case: I keep 3 different kinds of notes on each item. Here's how I'd like to set up my custom default template:

    • Account name/Company/Whatever
    • URL
    • Login (username or email)
    • Password
    • Email (if not the same as login)
    • Account details — this is a particular kind of note where I include..
      • Serial#s
      • Recovery information (e.g., alternate email addy)
      • What personal identifying info I've provided (DOB, address, etc.)
      • How much the subscription costs
      • What you get for the price (e.g., Microsoft 365 includes 5 users, who each get 1TB of OneDrive, etc., etc.)
      • Support ph#s and operational hours (this is why a "phone" field by itself isn't of use to me)
      • Other contact information
    • Notes — general notes for information like...
      • Why I created the account
      • Experience-related information, for example...
        • "terrible phone support - use chat instead"
        • How to navigate to where PDF bills can be downloade
      • Things I need to do related to this account (e.g., "remember to sign up for user forums")
    • Events — history of my account
      • 2018-01-01 created account
      • 2018-02-01 signed up for paperless billing
      • 2018-03-01 forced to create new password
      • 2018-05-01 opted out of mailing list

    Yes, I could use the single existing Notes field for all of this, but that makes for very a cluttered field. So I'd like to see the option of adding more "Notes" fields.

    I'd also like the ability to put any and all notes fields wherever I want in the template, not just at at the bottom. For example, I'd like to have Security Questions at the very, very bottom of my template — below Notes — because I'm going to need access to the notes 100x more often than I'll ever need access to the Security Questions (emergencies only, really).

  8. Another problem/suggestion:

    About 30 times now, I have accidentally closed an item that I wasn't done editing by hitting [Enter] when I finished typing a tag name.

    I may be in the minority here, but I'd rather have only CMD+S be the only way to save and close the item, and have [Enter] be used to signal the completion of a field.

    For example, if I'm editing an item to change the password, and then add a note about the date on which I made that change, my natural flow would be to change the password, then hit [Enter] to indicate I was done in that field. (I would not [Tab] in this case because I'm very specifically not moving on to the next field.) Then I would click on Notes and add my note. Then I would use CMD+S to save my changes and exit the item.

    Oh, and that's another big problem: CMD+S doesn't do anything when you're creating/editing an item. CMD+S should always save and close the item, regardless of what you end up doing with the [Enter] key.

  9. 21 hours ago, Anshu kumar said:

    I appreciate your feedback and suggestions that you have provided. I've noted it down and forwarded to the concerned team for further consideration. Thanks again for taking the time out of your day to share your valuable ideas.

    I'm always happy to get involved when I find just the right software for me. I've fiddled around with several password managers, and Enpass is the clear winner. Very happy to be part of the beta. Cheers!

    • Like 1
  10. Speaking of Categories (previous post), I'd like to suggest some changes:

    1) Credit cards are Finance — I don't understand why they're separate

    2) Insurance should be separate from Finance

    3) Shopping should be a category (Amazon, Target, eBay, Etsy, etc.)

    4) Social should be a category (Facebook, Twitter, Reddit, etc.)

    5) Utilities should be a category (gas, electricity, phone, internet, etc.)

    6) Maybe Media as its own category (Netflix, Hulu, Roku, Vudu, Kanopy, JustWatch, etc.)

    Or maybe categories could just be user-editable, so I could put Credit Card into Finance and remove Insurance from Finance?

     

    Also, I'd much rather have just one template called "website" than dozens upon dozens of literally identical templates that differ only in their icon and URL (both of which can be added by the user in seconds, once the custom icon UI works better by just scaling an image instead of making a mess of any image that isn't exactly 200x200). This way I'm not stuck with tons of templates I'll literally never use and just get in the way. (Maybe others feel differently.)

    Also the Add UI is in dire need of a Back button. If you accidentally click the wrong template, you have to start over from scratch.

  11. Was just fiddling around with creating my own Categories, and found that once you do, you're a little bit stuck.

    When you go to create a new Item in that category, you're told "No templates found in this category. You can add a new template from Customize settings."

    A couple points here:

    1) It's impossible to get to Settings directly from Add Item (CMD + comma should open Settings/Preferences regardless of where you are in the app — this is part of the Mac-unfriendly UI people have mentioned upthread — I can live with this UI, but as I noted previously, it does make the Mac version of Enpass feel like an afterthought porting of PC software, and this version is definitely not as easy or intuitive as Enpass 5 for Mac)

    2) When creating a new category, adding templates to it should be part of the process (obviously you need templates for your category)

    3) Having to go to an entirely different place in the app to do this is very user-unfriendly

    4) Short of fixing #2 (thereby also fixing #3), at the very least the instructions should be clear:

          - "You can add a new template by going to Settings > Customize > Templates"

    5) HOWEVER, Once in Settings > Customize > Templates, it's impossible to assign any existing templates to the new category. You have to either create a new template or duplicate an existing one.

    SUGGESTIONS:

    a) When creating a new category, there should be an option of moving existing Items into that category

    b) When creating a new category, there should be an option for including exiting templates in that category

    c) CMD + comma (and Enpass menu > Preferences) should bring up Preferences no matter where you are in the app (and they should come up in their own window, as is standard for Mac apps)

  12. On 8/11/2018 at 4:35 AM, david said:

    enpass 6 doesn't grab favicons from homepages either

    FYI, I'm pretty sure that's coming soon. This is just the first beta build, and I remember seeing somewhere that grabbing favicons isn't in this build, but it will be in a future build. Can't find where I saw that right now, but I'm pretty sure...

    • Thanks 1
  13. Another request: Templates you've made yourself should be grouped at the top of Templates. Short of that, they should at least be recognized in alphabetical order. I put parentheses around the name of my template, assuming that would make it appear at the top (as happens with file names in the Finder), but no dice. Every template I made myself is at the bottom: 207 templates down. That's a lot of scrolling. (I know I can search, but that's beside the point. I should be able to get to my templates that I know I will use almost every time without the extra steps.)

    BTW, why aren't templates in alphabetical order? And also, BTW, the scrolling throughout Enpass 6 is not at all smooth. I just scrolled through all the templates to count them for making my point above, and it was difficult to scroll to any precise point.

     

    :)

  14. NEW ISSUE:

    When I have a particular tag or category selected in the sidebar, then I go hit the [+] to create a new item, I expect Enpass to assume I want to create an item within that tag or category. This doesn't happen.

     

    ALSO:

    Tags need to be located near the top of the Edit Item screen — I'd suggest right after URL. Having to scroll all the way to the bottom on some of those templates is a significant hassle. All the fields you're most likely to use should be at the top: User, email, pass, URL, tags.

    BTW, when creating your own template, there doesn't seem to be any way to add a Tags field or a Notes field. It turns out they show up on their own, but that's not at all clear when you're in the process of creating the template, and not having them available also makes it impossible to choose where they go. I want Tags at the top and Security Questions below Notes (which I need far more often), but as near as I can tell, that's not possible in Enpass. (And when creating a new item, [Add Field], [Add Section] and [Add Attachment] should be at the bottom, not taking up room in the middle, forcing uses to scroll to get to Tags and Notes.)

     

    ALSO:

    There are too many steps to creating a new item. In Enpass 5, you could just click [+] > Login, and you'd be entering your data. Now there's a whole extra step in which you have to choose a template, 90% of which I'll never use, and at least half of which I've never heard of. At the very least, allow users to audit/delete/hide templates so they're not having to scroll through dozens they'll never use on the off chance that one they might want could be in there somewhere.

    Here's the thing: How different, really, are those dozens of templates? I mean, other than the icon (which you can add yourself), what's the point of having a template for, say, AccuWeather? Especially when you don't have templates or icons for any other weather service? There really only needs to be separate templates for separate kinds of accounts that might have very different fields. If you have 40 templates that all have the same fields, you're just making it more difficult than is necessary for creating new items.

    And on the subject, in addition to being able to delete custom icons, users need to be able to delete custom templates too. If you make a mistake on a template or icon, you shouldn't have to live forever with that clutter in your Enpass UI.

    BTW, creating a new item is one area where the Windows-like UI falls down: Click [+]...wait for Add Item overlay to load...click "Login"...wait for Choose Template to load...click "Default"...wait for Add screen to load. It's less than a second each time, but do a test: Create a new item in Enpass 5 for Mac, then do the same in Enpass 6. Enpass 6 takes at least twice as long. Enpass 5 was quick and easy. Very much not the case in Enpass 6.

     

    Overall, still happy with the new version. But the user-friendliness needs some work. :)

     

  15. Thanks for diving in with a big batch of replies, @Vikram Dabas! Very much looking forward to the next beta release.

     

    14 hours ago, Vikram Dabas said:

    Further, in Enpass 6, we have revised the password entropy to strength the range which could lead to lower strength labeling of previous passwords. However, an 18 char (non-diceware) random password shouldn't be shown as weak, so please let us know if the password is pronounceable or non-pronounceable. Also, if possible, can you share a similar type of password via DM so that our team can investigate it further?

    That probably explains it. My passwords are strong, but are partially pronounceable and while they might look fairly random to the human eye, maybe not so much for a password checker. I'll DM you a fake sample.

     

    14 hours ago, Vikram Dabas said:

    Also, we've tested the issue regarding the custom icons in our labs, and it's working correctly. So take a closer look at the problem, we might require some further information from your side:

    • The devices and their respective OS version.
    • When does the issue occur- while setting a custom icon on a new item or editing existing items?
    • Does the issue occur with the particular items or all of them?

    1) Both devices are MacBook Pros (2009 & 2010) running 10.11.6

    2) I think the order in which things happened was:

    • create new item by hand
    • realize while creating it that Enpass doesn't have an appropriate icon
    • save anyway so the record is there while I go hunt for the custom icon I want
    • go back to the record after finding an icon, click Edit, click icon, click the (+) to add my own
    • (I'll skip the part where I tried 4-5 icons before figuring out that a custom icon has to be exactly 200x200 — Enpass needs to scale, not crop!)
    • after finally getting the icon I want, I'm done on Computer 1
    • Later, I'm setting up Enpass 6 on Computer 2, and you can pick up the narrative from my original Steps above.

    3) So far I've only tried custom icons with one item that is in a shared vault, so I don't know about recreating. Sorry.

     

    BTW, Enpass needs a coffee cup icon and icons for every letter and every number. Why does Miscellaneous only include G, H, I, P, Q, R, X, Z for letters and no numbers? 

     

     

     

  16. Found a new bug: If you create and use a custom icon, it does not sync between devices.

    Steps to recreate:

    1) In an existing Enpass 6 vault (synced via Google Drive, if you want to reproduce exactly), create a new record and add a custom icon (BTW, see my previous posts about all the problems with creating custom icons that actually work!)

    2) Go to a second computer, install Enpass 6, and sync that vault onto this second device

    RESULT: record with a custom icon has no icon at all on this second device

    I believe this relates to how the icons are stored, which is very strange:

    If you dig into where they're stored (Library > Containers > in.sinew.Enpass6-Desktop-Beta > Data > Library > Application Support > Enpass6 > temp), you'll find that when you quit completely out of Enpass 6, those custom icons disappear completely.

    When you launch again, they return.

    While Enpass is not running at all, if you search for the file name of any of those icons (using a search tool that isn't crippled like Spotlight — I use Find Any File), there's no sign of them anywhere on your drive.

    So when Enpass 6 isn't running, it must stash those custom icons somewhere completely hidden.

    That's problematic in itself, but what I'm getting at here is that I'm not surprised an icon buried that deep in Library > Containers doesn't get shared when you sync across devices — and there's no point in using custom icons if you can't sync them across devices.

    So in addition to the problems described upthread, this is another sign that custom icons may have a ways to go yet.

    Hope that's helpful Vikram and team.

  17. On 7/28/2018 at 1:12 AM, pio93qwertz said:

    The history menu item is only provided if you changed some value in the past.

    Ahhh. Well, that explains it.

    I think it would make more sense for "History" to always be there (so people know it exists!), but shows empty results if there have been no changes. Consistency makes for a better UX.

  18. 9 hours ago, pio93qwertz said:

    Right clicking to any field provides a context menu with an option for "history". The complete history of a field is also inside the JSON export.

    I'm trying to duplicate this, but I'm not seeing "History" in the contextual menu for any field, but only for the password field. Everything else has only one item in the contextual menu: "Copy"

  19. Just rebooted for the first time with Enpass 6 installed, and instead of launching (at startup) in the background like Enpass 5 (where it just shows up in the Menu Bar, ready to use as needed), Enpas 6 launches the full app, landing on the master password prompt.

    Of course, very few people will need to login to Enpass to retrieve or edit account information upon starting up their computer, so I'm hoping this gets fixed.

     

    Just so I'm not filling this forum with bugs and other issues, I wanted to take a minute to say that I've started a second vault for the first time, and I'm thrilled to have this feature. This was the one thing I was waiting for before committing fully to Enpass. I like the way it's executed, especially the CMD+1, CMD+2 vault switching and the display in the Vaults menu of which cloud service is used for backing up each account. I also appreciate that the app has so many key commands in general. This makes it very easy to navigate — although as mentioned above, ESC to get out of various screens is sorely missing. It's there for some things (you can ESC out of creating a new item), but not there for others (you can't ESC out of editing an item).

    Cheers!

  20. In Enpass 5, after unlocking Enpass's Menu Bar overlay, if you then Show Enpass, the app interface opens right up.

    In Enpass 6, after unlocking the Menu Bar overlay, when you then Open Enpass, the app interface always asks you for your master password again, even if you literally entered it seconds ago in the overlay.

    I hope this isn't by design, as it's a hassle.

     

    Also, another usability note regarding the un-Mac interface: Navigating the preferences is cumbersome. In the Mac-friendly Enpass 5, you go to Preferences, and it's very easy and quick to move from tab to tab for the various kinds of settings. In un-Mac-like Enpass 6, switching from one settings category to another is a multi-step process involving a back button. Not a huge deal, but it's user-UNfriendly.

     

    I'm also unclear on whether or not it's safe turn on cloud syncing in Enpass 6. I did, and now Enpass 5 won't sync, and there's only one .walletx file in the Enpass folder of my cloud account. The most recent sync was yesterday in Enpass 5, even though the most recent attempt was today. But in the first post in this thread it says, "you can use your existing cloud accounts to test the sync in Enpass 6 without any interference to sync in stable Enpass 5."

     

    BTW, this forum thinks every browser I try to use is a spambot. Chrome, Chromium, Safari, Firefox, Brave, no matter which, I get either the error message in the attached screenshot, or one just like it that says I've submitted too fast and to wait several seconds and try again (in reality, I have to wait 10-30 minutes before trying again). Each post I've made here has been a 20-30 minute process just getting the [Submit Reply] button to work.

    discussion.enpass.io error.png

    • Thanks 1
×
×
  • Create New...