Jump to content
Enpass Discussion Forum

[solved] Absolutely unable to import from 1Password: "Notihng to import"

Thats I Am

Recommended Posts

I bought the One-Time-Plan from Enpass and now I wanted to import the vault from 1Password into Enpass.
Unfortunately I always get the message "Nothing to import", no matter what I try.

I have searched here in the forum and the solutions in the topics I found, unfortunately didn't work. Therefore I kindly ask here for help with my problem.

The technical data:

  • Computer: MacBook Pro 2015
  • OS: macOS 10.14.6, no tweaking software, no virus scanner or similar installed
  • 1Password: Version 7.6
  • Enpass: Downloaded from enpass.io, version 6.50 (707)

My previous approach:

  • Installed Enpass
  • selected "New user"
  • set master password
  • in the app logged in to Enpass with my registered e-mail address (login worked)
  • quit Enpass and restarted, entered master password and was in the Enpass standard vault.


  • In 1Password, select my main vault (I have two vaults)
  • File -> Export -> All items
  • entered password for the vault
  • selected *.1pif file format
  • saved to the desktop with the name "Tresor_Export.1pif
  • A folder named "Tresor_Exort.1pif" appeared on the desktop with a size of 71 MB (this is approximately the size of the 1Password main safe) and containing a file named "data.1pif" and two folders named "attachments" and "previews".


  • In Enpass: File -> Import -> 1Password
  • In the dialog selected 1PIF and at "Folder" I chose the folder "Tresor_Export.1pif" on the desktop.
  • Clicked on "Continue", a wheel appeared for a few seconds, then the message "Nothing to import" appeared.

To be sure that I didn't make a mistake, I also completely resetted Enpass (including deleting backups), but even that was unsuccessful.
In 1Password I used the tool "Opitimize Database" and then I exported again and tried to import into Enpass. This also ended with the message "Nothing to import".
I also have a Windows 10 BootCamp partition, in which I did the same as described above, but also ended with the message "Nothing to import".

My 1Password vault contains about 750 entries. These are online logins, software licenses, program passwords, identities, notes etc. Many of the entries also have attachments. These have the file formats PDF, TXT, JPEG and some attachments are license files of programs.

Now I hope that someone else can help me with tips and tricks and I will still be able to transfer my main vault from 1Password to Enpass. I don't like to transfer this large Numer of entries with their attachments manualy.

Many thanks in advance.

Edited by Thats I Am
Link to comment
Share on other sites

I've had the same issue.
When exporting from a 1password v4 it does not work at all.
I used v7 to export to 1pif. This did not import ALL the items (export 400, import 106)
but using a text editor and looking at around line 212 showed me a weird looking entry.
After i removed it enpass imported 290 items so i repeated the same as above.
I needed to repeat another two times and now everything is imported.


  • Like 1
  • Thanks 1
Link to comment
Share on other sites

@Julian124, thank you so much for taking the time to share your experiences with me.
I exported with 1P version 7 and then viewed the *.1pif file in BBEdit. But I did not notice any weird looking entry.
Nevertheless you helped me, because you gave me a new idea which finally led to success.

Here's what I did (I describe it a bit more detailed so that other users who have the same problem can try if this way works for them)

  1. In 1Password I did not export all elements, but selected 200 items in the vault I wanted to export.
  2. Then I exported them via File -> Export -> Selected Elements
  3. I named the export file "Export_part_1.1pif".
  4. In Enpass I selected the folder "Export_part_1.1pif" via File -> Import > 1Password -> PIF at "Folder" and clicked on "Continue".
  5. Enpass then showed that 200 items can be imported and I clicked "Continue".
  6. After a short time I got the message that 200 elements were successfully imported.
  7. I checked a large number of imported entries randomly to see if the import including the attachments was correct and I was happy to find out that the data including attachments was imported correctly.
  8. Then I repeated steps 1 to 6 (export as "Export_part_2.1pif", "Export_part_3.1pif" etc.) and each of the imports worked without any problems.

In the end I again checked the imported data randomly and it looks like all elements and attachments were imported completely and correctly to Enpass.

Now I can go on and get familiar with Enpass and also try to establish synchronisation of the vault.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...