Jump to content
Enpass Discussion Forum

BUG: "Connection Error" in browser, even when Enpass.app is running and visible (b6.6.0.765 & before)


Recommended Posts

This problem has been going on since at least b6.5.0.701, but I was never sure if it related to the problem I previously reported about the Enpass.app window rendering transparent upon launch/relaunch. Since I have not (yet) had the transparent-window problem in 6.6.0.765, I'm reporting this bug now.

Frequently (every day or two), when I bring up Enpass Assistant within a browser (my "daily driver" is Brave, but it happens in Chrome too), I get the "Enpass Assistant is unable to connect with the Enpass app") error...even when Enpass is not only running, but actually has an open session, with the Main Window active in the background.

When this happens, clicking the [Open Enpass] prompt in the browser actually closes Enpass.app.

The only way out of this is to quit Enpass.app completely and relaunch it. This when, in b6.5.0.701, the transparent-window problem would occur, and I'd have to quit & relaunch 5-15 times before the Main Window would correctly render. Fortunately, that has not (yet) been the case with 6.6.0.765. After relaunching, Enpass Assistant goes back to normal behavior (which is often rather slow and sometimes unreliable, but that's a story for another thread).

Illustrated screenshot attached.

2021-01-29 Enpass %22connection error%22.png

Link to post
Share on other sites

Hi @100 Watt Walrus,

Sorry for the inconvenience caused to you.

To investigate this issue, we need input from you, so please share the following details:

  • Did you make any changes to the keyboard input source?
  • Please check if you have installed two Enpass App versions on your system- both the website and store version.

Thanks for your co-operation.

 

Link to post
Share on other sites

Hi Pratyush...

  • Did you make any changes to the keyboard input source?

If by "keyboard input source" you mean did I customize the system-wide hotkey or the CMD+/ browser shortcut, the answer is no. If you mean something else, please clarify.

  • Please check if you have installed two Enpass App versions on your system- both the website and store version.

I have only one install of Enpass.app — b6.6.0.765.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...