Jump to content
Enpass Discussion Forum

Enpass Core Dumps since 1.8.0 when Wi-Fi sync enabled

Bob H.

Recommended Posts


I run Enpass on Arch linux via the AUR enpass-bin package.  I also use Wi-Fi sync to sync my desktop with my phone and other devices on my network when they are connected instead of a cloud provider.

Since 1.8.0, enpass ends up in a random core-dump usually after I have enabled Wi-Fi sync.  I have also tried 1.8.1 with the same results.  However, I can run without issue.  It seems something has changed in 1.8.0 that is causing the program to core dump.  I've sent numerous bug reports when this happens so that hopefully the team can investigate.  I know I'm not running debian or a RPM distro, but the AUR script is installing from the Debian package.

Please let me know if the team needs any additional information regarding these crashes.  I'm not sure if the bug reports are sufficient in troubleshooting the issue.



Edited by Bob H.
Link to comment
Share on other sites

No worries!  I know there are many flavor's of linux and it can be challenging at time.  I've been trying different things, and here's what I've come across.

When I install the newer versions, I'm restoring from an automatic backup (have them setup in 1.7.4 build).  When I restore, I've noticed that when I view the vault settings, Enpass still thinks it's setup WiFi sync.  However if I go to the WiFi Sync tab, it's not connected.  The application will core-dump a few minutes after I launch it.  So it's not really running WiFi sync server at all.  Seems like there is more than just the vault contents that are being backed up.  Perhaps there some type of sync configuration as well that is saved as part of the backup?  Keep in mind that I use my desktop as the source of truth and my other devices as clones that sync up when i'm at home.

I've attached images of the panels in the app to help. 

In a recent attempt, I've tried stopping the WiFi server in the previous 1.7.4 build to disconnect it from WiFi sync, then take a backup and load that backup in the new version as well.

Something I've noticed as well is that if I quit Enpass all together, when I launch Enpass again via the application launcher, I need to reimport from a backup.  It seems like it's not persisting state correctly.  This happens in 1.7.4 as well so there's something else going on here also.  Could this be some type of permissions issue?

Btw, I forgot to mention the system specs I'm running:

Operating System: Manjaro Linux
KDE Plasma Version: 5.24.6
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.18.10-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 2600 Six-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 580 Series




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...