Jump to content
Enpass Discussion Forum

Can't sync data with iCloud


Recommended Posts


(P.s. My English is not good, Thank you for your patience to read, sincerely.)

I tried to sync Enpass data between OS X EI Captian(Version 10.11.6) and iOS(version 10.2.1) with iCloud, but it didn't work.

The version of Enpass on my mac is 5.4.1(74)which I downloaded free from Appstore. I'd enabled Enpass to use iCloud service and synchronised manually to iCloud like the below images:QQ20170214-165546@2x.thumb.png.598c4c062c616e57ce17860fefa51f7e.pngicloud.thumb.png.2071d34d5d50849322de26da14de8790.png

I also enable the Enpass on my iPhone to use iCloud service, I choose the 'Restore my existing data' when I firstly opened Enpass and then tried to sync from iCloud, but responded like below:


It can't work with iCloud. Could you help me to solve the problem?

Thank you !


Edited by binflying
Link to comment
Share on other sites

Hi @binflying,

I am really very sorry to hear that you are having trouble in restoring the database on the iOS device. Please make sure you are using the same iCloud account on both devices. For quick troubleshooting please follow these steps:

  • Go to iOS device settings--> iCloud--> iCloud drive--> Turn off the iCloud drive and turn it on again.

If your problem still persists, please provide some more details so that we can investigate where the problem could be.

  • Which Enpass version are you using on the iOS device?
  • Go to Device Settings --> iCloud --> Storage --> Manage Storage --> Open Enpass Password manager --> And check for the sync_default.walletx file is there?



Link to comment
Share on other sites

Hi @binflying,

I am sorry that the workaround didn't help.:( I have noted this issue and forwarded to the dev team so they can try to fix this issue asap. Meanwhile please try these steps and let us know whether your problem gets resolved or not?

  • Turn off sync from all devices.
  • Open iCloud drive in any Browser --> Open Enpass Folder --> Select sync_default.walletx file --> Download and save it in your PC.
  • Now Delete sync_default.walletx file from iCloud.
  • Now open Enpass and turn on the sync one by one in both devices. 

Thanks for your patience!

Link to comment
Share on other sites

Hi @Anshu kumar,

Thank you for your patience to help me.

I solved the problem, but I didn't do anything. It is amazing when I opened the Enpass on my iPhone and tried to turn off the sync from iCloud by your way, I got the response below:


It works today!

I think there were something wrong with my iOS network yesterday. Maybe the vpn caused it or maybe not. The iCloud works good in China.

Sincerely, Thank you for your help and the Enpass team, I really like Enpass very mush.

  • Like 1
Link to comment
Share on other sites

  • semi_mod locked this topic
  • semi_mod unlocked this topic
  • 2 months later...
This topic is now closed to further replies.
  • Create New...