Jump to content
Sign in to follow this  
RASTPB

Cannot share Primary vault

Recommended Posts

I have Enpass Premium and want to share my vault with my wife.

I have only 1 vault, the Primary vault.

On my PC, Enpass stores the vault in \Apps\Enpass on my OneDrive for my Microsoft account.  On my wife's PC, Enpass stores the vault in \Apps\Enpass on HER OneDrive for HER Microsoft account.

How can I share my vault with her so we really only have one common vault?

Thanks in advance for any help and advice.

Share this post


Link to post
Share on other sites

Hi @RASTPB,

Thanks for writing in.

To share a vault via sync, you can either create a new account on any of the cloud providers or use any of your existing OneDrive accounts and follow the below steps:

  • Open Enpass on your phone and go to Enpass settings --> Vaults --> Tap on Primary ---> Select Sync and choose a cloud account to your database.
  • Enter your cloud account details, follow the instructions and wait till the sync is done.
  • Now open Enpass on your wife phone --> Vaults --> Tap on Primary ---> Select the cloud (as in Step 1) from which you had enabled sync on your phone.

Share this post


Link to post
Share on other sites

Pratyush,

      I greatly appreciate the reply, but this is not working.  I could be wrong, but it seems like an Enpass bug.

     First, just as an aside, I realized I had to Disconnect before the 'Select Sync' step you mentioned above.

      However, the real problem is that when I then hit 'Set up Sync', and then select OneDrive, I am NOT prompted for the Microsoft/OneDrive account to use.  Enpass just sets up sync again to the same OneDrive account it had been using before I did the Disconnect.

     On my PC (n.b., using Windows PCs, not phones), I tried this many times.  Finally I tried rebooting the PC and then the next time I tried 'Set up Sync' I did get the Microsoft prompt for the OneDrive account to use.

     I then did the same thing on my wife's PC and Enpass NEVER let me choose a new OneDrive account.   Rebooting didn't help either.  Then I un-installed Enpass on her PC, rebooted the PC, re-installed Enpass, and that did not help -- 'Set up Sync' still connected to her OneDrive account and I had no chance to tell it to use my OneDrive account.

     FYI, on some attempts I could see the URL in the Edge browser VERY BRIEFLY show "login.live.com" and then immediately change to "auth.enpass.io".  I'm just guessing but I suspect that is a clue as to why I'm not getting the Microsoft prompt  to specify the OneDrive account.  I have a video showing this; if you wish to see it please tell me how to send it to you as I cannot attach it to this post.

     I'm stuck on this so would really appreciate any guidance and help.

Thanks in advance.

Share this post


Link to post
Share on other sites

Hi,

Thanks for writing back in.

Please follow the below mentioned steps and revert if the issue persists:

  • Disconnect sync from all devices.
  • Open One Drive in the system's default browser and logout form the cloud account.
  • Now try to enable sync with your OneDrive account.

Hope this helps!

Share this post


Link to post
Share on other sites

Pratyush,

      That resolved it.  THANK YOU very much.

       Is that a bug in Enpass or an insufficiency in the documentation?

Again, thank you.

Share this post


Link to post
Share on other sites

Hello @RASTPB,

This is not a bug. Whenever sync is setup, Enpass looks for the logged in account of OneDrive via the browser. Since you have already a logged in account in the browser, Enpass directly takes the authorization and uses the same account. Thus in this case, we had asked you to logout first and then try again. 

I hope this helps to clarify. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...