Jump to content
Enpass Discussion Forum

Cant get iCloud sync to work anymore


Recommended Posts

I have an up=to=date Debian (10) installation and iCloud sync stopped working. On reconnecting not even the browser get started. I tried another browser as default, same result. Since I could not get Sync to work I totally removed Enpass and installled the latest version today.

When I choose iCloud sync  I get a message:  Error during recovering data (translated from Dutch) even before something else happens.

Any idea what could cause this problem? Debian is my main install and without Enpass....

Link to comment
Share on other sites

Hi @Krit,

Sorry for the inconvenience caused to you.

Please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Are you getting any error message or code during sync? If yes, share it with us.
  • Are you able to access all your data on any other devices.
Link to comment
Share on other sites


- Windows 10, PC

- IOS (iPad Pro 12.9 , iPhone SE)

- Debian, Manjaro, CentOS in Virtualbox on PC

- Debian on laptop AsusPro i7 8Gb

- ElementaryOS, Manjaro, MX Linux, OpenSuse, Zorin, CentOS, Solus, Ubuntu, Mint in Boxes on ASUSPro

I always have the last stable version of Enpass running.

I can access all my data on all other devices/os

After resedttingh Enpass, uninstalling it en installing it again after a reboot I dont get an error code on sync, I just get a message that Enpass will open the iCloud page but nothing happens as soon as I try to setup a sync with iCloud.

Link to comment
Share on other sites

Additional info:

Just installed Enpass in a VirtualBox containing a Debian 10.4 install that does not had an Enpass install before. The same result here, instantly after clicking iCloud this message occurs. No spinning wheel or other messages, no browser opened. (translation: Error during recovering data)


Schermafdruk van 2020-06-15 08-45-12.png

Edited by Krit
Link to comment
Share on other sites

Additional info: Just did a new install of Debian 10.4 this time with US English user interface.

Then installed Enpass, same result. So no other packages installed by me, nor the user interface language can be the problem.

Link to comment
Share on other sites

  • 4 weeks later...

Hello there, just like to "confirm" that I experience the same isssue on Kali Linux. Error message when trying to sync with iCloud is "Error while restoring data."

xxx@yyy:~$ uname -a
Linux kali 5.5.0-kali2-amd64 #1 SMP Debian 5.5.17-1kali1 (2020-04-21) x86_64 GNU/Linux

Thx for investigating!


  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...