Jump to content
Sign in to follow this  
Springcomp

Cloud-sync with OneDrive fails

Recommended Posts

I have been using Enpass with OneDrive sync for years on multiple devices - One Laptop PC, an Android smartphone and an Android tablet.

Recently, I noticed that synchronization fails on all devices. When I try to "resolve" the problem, it offers to re-sync with OneDrive - and prompts me that after this operation, the password for the data stored on OneDrive will change to the master password. This suggested that, somehow, the database itself is also protected with a password that may be different from the master password I have always been using for years.

At the time, the only thing I could think of, is that I recently installed Enpass on a second Laptop PC and synchronized from OneDrive. I only have access to this PC a couple days a week  but it is currently not running. I has been powered off before leaving the office for the last time.

So I stopped synchronization from both Android devices. I stopped synchronization from the main Laptop while deleting all the data from OneDrive. I made sure to delete the Enpass folder under Applications on OneDriven. I then reset the synchronization with OneDrive which allowed the local data to be synchronized to the cloud. It worked perfectly. I was then able to retrieve the synced data on my other two Android devices.

However, after a day or two, I noticed that the data would no longer sync on the PC with the same error. I checked and could not sync on any of my Android devices.

I don’t know what to do since synchronizing on OneDrive no longer seems to work reliable on  the long term.

I think this is a problem similar to this one:

https://discussion.enpass.io/index.php?/topic/17419-enpass-stopped-syncing-with-onedrive-due-to-bad-master-password/

 

I have performed the same steps to erase the data from OneDrive and setup synchronization again from all my devices at home, and it seems to stick for a time. I’m not sure what will happen when I boot up my work PC and try to launch Enpass, which will probably trigger a sync and... fail ?

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Hi @Springcomp,

We are sorry for the inconvenience caused to you.

If the problem comes again, please share the following details so that we can investigate where the problem could be.

  • On which devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Are you getting any error message or code during sync? If yes, share it with us.
  • Does the Date and Time setting set to automatic on all devices?
  • Does the last synced time get updated on the sync page?

Thanks!

Share this post


Link to post
Share on other sites

Hi, thank you for your reply.

Yes the problem comes again, very often.

Here are the answers to the questions:

  • I’m using Enpass on the following devices:
    • PC Laptop Surface Pro, Windows 10, Enpass v6.4.3 (666)
    • PC Laptop Lenovo ThinkPad P51, Windows 10, Enpass v6.4.3 (666)
    • SmartPhone Huawei P10, Android 9, Enpass v6.4.5.368
    • Tablet Huawei MediaPad M5 Lite 10, Android 8.0.0, v6.4.5.368
  • The error message during sync is:
    • Synchronization error
    • The password for the data on OneDrive is required.

image.png.79030536616625fe1a63daa2dd3c3516.png

When I press the "Resolve now" button, I get a prompt to enter the "password for the data on OneDrive".
I have no idea what this "password" is. I tried the Master password but it does not work.
The only way to solve this problem, is to stop synch’ing the data, erase the data from OneDrive, and resynch’.

Then on all the other devices, I have to stop synch’in and setup the synch’ again.

 

  • The date and time is set to automatic on all my devices
  • The date and time of last sync is updated on the sync page (until the error comes up again)

 

 

Share this post


Link to post
Share on other sites

HI @Springcomp,

We are sorry for the inconvenience caused to you.

We are working to solve this issue. An updated Beta version will be available in a week or so where we have made some changes. You could try reinstalling Enpass (after backing up the data) for a temporary fix to the solution.

Thanks!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...