Jump to content
Enpass Discussion Forum

Invalid database index


Recommended Posts

Hello.

I have a bunch of credentials for the same website, say: example.com

Each of the credentials, of course, have distinct usernames & passwords. One of the credentials' username is byhuy.

However, when I start searching for 'byhuy', for some reason, all of the credentials in that example.com website show up (expected behavior: only example.com with username 'byhuy' shows up)! I have triple checked and there was no hidden field that has the word 'byhuy' in it.

This issue only happens in that specific domain: example.com. I have many different domains, each with more than one credential and they work fine.

Is there a way to fix the indexing of the database? What should I do? It's very inconvenient when I have to scroll through hundreds of the entries just to find one single credential.

Thank you.

Link to post
Share on other sites
  • 2 weeks later...
On 1/21/2021 at 12:58 AM, Pratyush Sharma said:

Hi @afunworm,

Sorry for the inconvenience caused to you.

Please revert to us with the answer to the following queries and we will get it sorted out for you:

  • On which device (along with OS version) are you using Enpass?
  • Which Enpass version are you using?

Hi.

It's on Windows, but the indexing problem appear across all the devices -- my Pixel Book (ChromeOS), Pixel 5 (Android) and Windows 10.

Regarding the version of the software, it's the one currently on Windows Store, released on 08/10/2017. I don't see any different version or the version number from the Windows store.

Thanks.

Link to post
Share on other sites

Hi @afunworm,

We need a little input from you, so please check the possible reason that which might cause this issue.

1.Either this text "byhuy" saves under the Webform. To check, and please follow these steps:

  • Search for the particular items.
  • It will display the list of the items.
  • Click on one item --> on the details page, it will have the " show Webform" option.

screenshot-1.png

  • Click on it and check if the text " byhuy" is there. ( check all the listed items one by one).

2. The text " byhuy," saves under the listed items notes field. You can check if the notes field has this text.

Hope this helps!

 

Link to post
Share on other sites
8 hours ago, Pratyush Sharma said:

Hi @afunworm,

We need a little input from you, so please check the possible reason that which might cause this issue.

1.Either this text "byhuy" saves under the Webform. To check, and please follow these steps:

  • Search for the particular items.
  • It will display the list of the items.
  • Click on one item --> on the details page, it will have the " show Webform" option.

screenshot-1.png

  • Click on it and check if the text " byhuy" is there. ( check all the listed items one by one).

2. The text " byhuy," saves under the listed items notes field. You can check if the notes field has this text.

Hope this helps!

 

Thank you for your response.

1. I checked multiple items, there was no "Show Webform" option.

2. I also went inside each of the individual edit page of a few credentials, there was nothing in the note section either. The only fields available were Username, Password, Website, One-Time Passcode and the checkbox that says "Autosubmit Login" with no other hidden fields.

Thank you.

Link to post
Share on other sites

Hey @afunworm

It seems that the TOTP secret key having the words "byhuy" which you can view by following the options mentioned below.

  1.  Open Enpass app.
  2.  Search for the particular items.
  3.  It will display the list of the items.
  4.  Open any one of the item in edit mode.
  5.  Now copy the secret key and paste in any text editor.
  6.  And check if the secret key have 'byhuy' words.

To fix this issue you can edit the secret key in this format and save it.

Example secret key:  otpauth://totp/Google%3Aabcgmail.com?secret=ujwd33n3ni3tansqbvq4fba3ixlhx5ku&issuer=Google

The final secret key:  otpauth://totp?secret=ujwd33n3ni3tansqbvq4fba3ixlhx5ku&issuer=Google

Hope this helps!

Link to post
Share on other sites
54 minutes ago, Garima Singh said:

Hey @afunworm

It seems that the TOTP secret key having the words "byhuy" which you can view by following the options mentioned below.

  1.  Open Enpass app.
  2.  Search for the particular items.
  3.  It will display the list of the items.
  4.  Open any one of the item in edit mode.
  5.  Now copy the secret key and paste in any text editor.
  6.  And check if the secret key have 'byhuy' words.

To fix this issue you can edit the secret key in this format and save it.

Example secret key:  otpauth://totp/Google%3Aabcgmail.com?secret=ujwd33n3ni3tansqbvq4fba3ixlhx5ku&issuer=Google

The final secret key:  otpauth://totp?secret=ujwd33n3ni3tansqbvq4fba3ixlhx5ku&issuer=Google

Hope this helps!

Hi.

Thank you for your response. However, none of my TOTP has 'byhuy' in it. An example of one of my TOTPS:

H5JQYR7FRROOR7LE

Thanks.

Link to post
Share on other sites
  • 2 weeks later...

Hey @afunworm

We are able to reproduce this issue using the below steps-

  1. Create an item with web-form. Make sure it has some fields in web-form.
  2. Make its duplicate.
  3. Delete web-form from duplicated item.
  4. Try searching with any field value which was present in web-form.

Please confirm if you have performed the similar steps, which resulted the mentioned issue?

Link to post
Share on other sites
On 2/22/2021 at 3:13 AM, Garima Singh said:

Hey @afunworm

We are able to reproduce this issue using the below steps-

  1. Create an item with web-form. Make sure it has some fields in web-form.
  2. Make its duplicate.
  3. Delete web-form from duplicated item.
  4. Try searching with any field value which was present in web-form.

Please confirm if you have performed the similar steps, which resulted the mentioned issue?

Hi,

Yes. I remember duplicating some of the items, and auto-add some of the other items. Do we have any work around for this?

Thank you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...