Jump to content
Enpass Discussion Forum

Webdav on Synology Nas


Recommended Posts

Disregard!  Apparently there was an update somewhere, or I changed the right setting in DSM and I was able to get it to work across all platforms.  I created a new folder and basically started from scratch and went into every permission and security setting I could find to ensure they were set properly. 

Sync is working for me now.  DSM 7, current WebDAV, and clients on Windows, iOS, and MacOS. 

  • Like 1
Link to comment
Share on other sites

Good morning.  I had this same error with both my PC and Android on DSM 6.2 and DSM 7.0, some time around June/July 2021 syncing stopped.  After the upgrade to DSM 7.0 I thought that would fix the issue.  I looked to convert the permissions to ACL as noted here but tried something else first.  What solved my issues was leaving the permissions as they were but I went into the  file station, to the webdav folder, I right clicked on the folder where I store Enpass, went to properties, and checked, "apply to this folder, sub-folders and files" under owner this re-pushed the folder permissions down again and after I did that everything started working again. 

It appears an update may have broke the permissions on the webdav folders, that's why converting to ACL or re-pushing permissions seem to work.

Just passing along what worked for me.

 

  • Like 3
Link to comment
Share on other sites

  • 1 month later...

Any Updates here? The current solution is quite disapointing if you have more user on the NAS and they're using their Home folders.

 

Also the same issue does not come up with other WebDav services / Apps

Edited by chase
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...