Jump to content
Enpass Discussion Forum

Windows iCloud sync problem - invalid session ID


Recommended Posts


I run enpass on a windows 11 desktop with iCloud sync and it worked fine for about 2-3 weeks.
I had to enter the icloud login credentials from time to time but that was ok.

Now when I try to reconnect to the icloud in enpass the following happens:
- The browser opens with the icloud page where I can put in my login credentials (like before when it was working).
- After I put in my login credentials I get the 2-factor code question on my IOS device (also fine).
- But after I enter my 2-factor code in the browser I get to a page where it sais "Die Anfrage konnte leider nicht abgeschlossen werden. Grund: Invalid Session ID". (screenshot attached)
I'm from Germany so I guess this translates to something like: "Unfortunately, the request could not be completed. Reason: Invalid Session ID"

I already tried to disconnect enpass from the icloud sync but I can't reconnect (same problem).

Hope you can help me out,


Edited by ToD
Link to comment
Share on other sites

Hi, it's me again - I opened this topic.
Not sure how the enpass support works - is a staff member going to reply here?

I'm not very happy with the situation. I bought this tool specifically to sync my windows machine via icloud with my IOS devices and now this is not working.
I would really appreciate some help or advice.


Edited by ToD
Link to comment
Share on other sites

Hello @ToD and @Glarre,

Welcome to the Enpass Forum.

I appreciate your efforts in reporting the presence of this issue in Windows 11. Our team has tested it and found it working as expected. For further investigation, please share the Enpass version (Store or Website downloaded). Your patience is highly appreciated here. 

Also, you have mentioned that you have to log in to iCloud credentials every time, for that I would suggest you to visit FAQ



Link to comment
Share on other sites

Hi there,
for me it's the same: Enpass version 6.7.2 (886) downloaded from website.
And I have Chrome (
Version 95.0.4638.69) as a webbrowser.

Some additional Info (not sure if this helps):
In Chrome I can lock into my icloud account without any problems. (Apple Music also no problems).
I also tried to click "I trust this browser" after logging in to my icloud account and then tried to the sync enpass (within the same session).
But also no luck - I get the same error message.

Edited by ToD
Link to comment
Share on other sites

I got exactly the same issue. Tried everything i found but still doesn't work. This problem seems like to exist for a long time and it still couldn't be fixed. I've tried to use Firefox, Chrome, Microsoft Edge... Nothing works and my devices and softwares are all updated. Hope this issue can be fixed very soon since I don't want get used to it. I don't know what to do anymore .... Always get the error "Invalid Session" but I can login into Apple and use everything else...
Kind regards

Link to comment
Share on other sites

Hi Enpass team,
I just wanted to check in again.
Can somebody from the team please respond here? This is getting really annoying.
Obviously I'm not the only one having this problem. So to have some sort of statement would be nice.
I'm slowly running out of patience.


Link to comment
Share on other sites

  • 1 year later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy