Jump to content
Enpass Discussion Forum

Enpass Desktop App not Starting with Nvidia Drivers (Ubuntu 20.04.3)


Recommended Posts

Hi, I have noticed that enpass (as installed by the instructions on the downloads page) does not open at all if I am running NVIDIA's proprietary drivers (I have tried v470 and v460 both installed via ubuntu's "additional drivers" settings page).

I am running a clean install of ubuntu 20.04.3 directly from their website that I downloaded earlier today, I reinstalled just to try and get enpass working.

With the nvidia drivers, if I run enpass using the command line (/opt/enpass/Enpass), nothing appears for a while but I hear my PC fans spin up and can see the "Enpass" process in system monitor. Eventually I get 84 "QQmlComponent: Created graphical object was not placed in the graphics scene." messages followed by a "Killed" message all at once.

However, if I choose the non-proprietary "X.org X Server - Nouveau display driver", click apply and reboot, enpass launches just fine from its icon.

What steps do I need to take to get enpass to work with the proper nvidia driver, which is essential in my case?


Here are my PC specs in case you need them:

CPU: AMD Ryzen 5 3600

GPU: Nvidia RTX 3060Ti

Motherboard: GIGABYTE B550 Aorus Pro V2

RAM: HyperX Predator 3600Mhz 26Gb

PSU: Cougar 100W Bronze

Link to comment
Share on other sites

  • 4 weeks later...

Having exactly the same issue.

CPU: AMD Ryzen 9 5900X

GPU: Nvidia RTX 3080Ti

OS: Ubuntu 20.04.3 LTS

When i install enpass via snap store, i get the following error message:

Gtk-Message: 18:34:50.871: Failed to load module "canberra-gtk-module"

Again, if changing the nvidia driver from nvidia-driver-470 to the X.Org X server, Enpass is able to start, but the error message still appears.

re-installing the canberra-gtk-module does not solve the issue.


Thank you for looking into it :)

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...