Jump to content
Enpass Discussion Forum

Enpass multiple vault folder sync broken

Axxel H

Recommended Posts

Having encountered the crash with this version, I took the usual step of clearing data and attempting to set up the app from scratch. While the fresh install does not crash, it does not allow syncing more than vault via folder (I have not tried other sync styles).

I have multiple vaults, one for personal, one for work, etc. Each vault has a separate folder sync location on Android. This has worked with previous builds.

In this build I can create a new vault "Personal" with the same vault password that I use for the synced vault on other platforms. I do not store the vault password in the primary vault (this was not required previously). If I configure this vault to sync, it works fine and the empty vault is populated with sync information from the folder as expected. Multiple syncs can occur without issue.

Then I add a second vault ("Work") with its own (different) password and set it to sync with a different folder. This also works, populates the new vault with the appropriate information, etc.

However, as soon as I add the Work vault sync, the Personal vault sync begins to fail and reports the wrong password. Entering the correct password for that vault does not allow it to sync (reports incorrect password). If I disable sync for Personal, and then reenable it with the correct password, it begins to sync again, but immediately breaks the Work sync in the same way.

This pattern repearts for vault 3, 4, etc. At any time only the most recently configured vault for syncing works, all the others reports they have the wrong password, even though they were able to sync before. Its almost like Enpass has forgotten that each synced vault can have its own password.

Link to comment
Share on other sites

Hi @Axxel H

Apologies for the hassles caused to you in this matter. Kindly share the below details with me and I'll get this investigated for you -

  1. The version of the OS you are using on which you are facing this concern.
  2. Are you also encountering any error message with this issue? If yes, kindly share a screenshot of it with me.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy