Jump to content
Enpass Discussion Forum

Restore from webdav broken in V 6.8


Recommended Posts


since version 6.8 it is not longer possible to restore multiple vaults from the same webdav server. I receive the message that the same account is already connected.

But it is not the same account. It is just the same URL to the webdav server. The account has a different username and password.

Until version 6.7.4 it was possible to connect to multiple vaults fron the same server. It seems that this version just checks if the server address is already used and not if this is a different account. In 6.7.4 I sync about 8 vaults from the same server





Link to comment
Share on other sites

Hy Manish,

I test both versions. Store and download version have the same behavior. I install 6.7.4 and install all vaults. After that the version 6.8 did not start with the data base anymore

Macbook pro 14" max amd Macos version 12.3.1


Link to comment
Share on other sites

Hi @lalelunet,

Thank you for reporting the presence of a database detection issue in v6.8. I suspect it could be a permissions issue. Try on your Mac, choose the Apple menu -> System Preferences -> Click Security & Privacy -> Click Privacy -> Select Files and Folders -> Select the checkbox below an app to allow it to access files and folders in that location or you can add Enpass manually if needed. You may need to click the lock icon and authenticate before you can add or change any items listed there. Let me know if that helps. 

Link to comment
Share on other sites

  • 2 weeks later...

I, too, cannot recover data from my WebDAV server on a newly installed copy of the program. I restored from a backup, but I can not connect the synchronization. Writes about an incorrect login / password, although the file manager connects to the server with the same credentials without any problems. OS - Ubuntu 22.04. One gets the impression that starting from some copy, the program stops working normally. But where then can you delete information about registered but unused copies of the program?
I often reinstall the OS. And I don't have one computer. What is the maximum number of registrations before the program fails? This information does not exist.
Please help.

Link to comment
Share on other sites

Hi @Сергей Сидоренко,

Welcome to the Enpass Community Forums. 

Thank you for reporting the presence of this issue. Recently, we have rolled out a new Enpass version 6.8.1 for Linux. Please confirm if you are using the same Enpass version. Further, please share a demo account along with its username and password as well as its URL to allow us to investigate it better. For security reasons, please share the details in a personal message or on support@enpass.io.

Link to comment
Share on other sites

  • 2 months later...

Any news on this?

I can confirm that is the last working release on Linux platform. I have 4 vaults connected to the same webdav share mapped to the users home folder, so the path on the server is different for each vault. It seems that the introduction of Enpass-Business in V6.8 has brought some incompatible changes. In 6.8 I can only sync one vault to the webdav share. I get the above mentioned error if I try to restore a second vault.

If this is a feature rather than a bug, the possibility to sync multiple vaults to the same sync share is severely hampered. I don't want to sign up to 4 different cloud providers just for Enpass.

I sincerely hope there is a solution for this issue.


Edited by Alexander Pohl
Link to comment
Share on other sites

I am seeing the same issue.  I have multiple WebDAV vaults that have worked successfully for 2+ years.  I am a premium user and can connect to them from my Windows 10 machine using Enpass 6.8.2 (1084), on my iPhoneX using Enpass 6.8.1 (633), but on my new MacBook (Apple M1 Pro) running macOS Monterey 12.3  I cannot add them all. The MacBook is running Enpass 6.8.2 (1082) from the Mac App Store.  On the Mac I was able to get a second WebDav vault to work, but could not add anymore after I added the second one.  Note a week prior it would not let me add the second folder with the same error I am getting now "No two vaults can be connected to same account for syncing data.  Connected Vault: Family All"


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy