Jump to content
Jan

Starting browser for Google Drive sync. does not work with Qt 5.7

Recommended Posts

Hi, I'm on Arch Linux with Plasma 5.7.1 and Qt 5.7.0. Enpass uses kde-open5 to open a browser, which fails:

kde-open5: /home/jan/Enpass/libs/libQt5Core.so.5: version `Qt_5.7' not found (required by kde-open5) 
kde-open5: /home/jan/Enpass/libs/libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/libKF5KIOWidgets.so.5)
kde-open5: /home/jan/Enpass/libs/libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/libKF5KIOCore.so.5)
kde-open5: /home/jan/Enpass/libs/libQt5Core.so.5: version `Qt_5.7' not found (required by /usr/lib/libKF5Service.so.5)
[...]


Possible fix: Reset environment vars when starting a QProcess(?).

Hack: Start Enpass and temporarily rename the libs/ dir, which makes kde-open5 use the system's libQt5Core.so

 

Share this post


Link to post
Share on other sites

Ok found the problem. We use QDesktopServices to launch browser. It is happening when Qt used by KDE is newer than Qt shipped with Enpass. We are planning to abandon use of QDesktopServices in next version and use xdg-open instead to avoid this type of problem.

As a fix, you can either Setup Enpass sync in a desktop manager other than KDE or use folder sync for now.

Share this post


Link to post
Share on other sites

Hi Vinod... I just signed up for the beta program using Linux platform. Just wondering will the new xdg-open method will be part of the beta at some point? I'll look for the workaround mentioned.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...