Jump to content
Enpass Discussion Forum

openSUSE Tumbleweed Issues


Psyko

Recommended Posts

Edit: What is wrong with the spam protection!? it is really annoying! i was blocked because of "root@localhost"...

---------------------------------------------------------------------------------------------------

Hello Enpass Team,

first, Thanks for the great new Update!!! But i found some issues which i would like to inform you. I ran:

wget https://yum.enpass.io/RPM-GPG-KEY-enpass-signing-key
sudo rpm --import RPM-GPG-KEY-enpass-signing-key
sudo zypper ar -f -c https://yum.enpass.io/stable/x86_64/ Enpass

FYI -t gave me this error, so maybe you should remove the -t

Warning: Legacy commandline option --type detected. This option is ignored.

Then i refresh my repo list but i get this error:

localhost:~$ sudo zypper ref   
Retrieving repository 'Enpass' metadata -----------------------------------------[|]
Warning: File 'repomd.xml' from repository 'Enpass' is unsigned.

    Note: Signing data enables the recipient to verify that no modifications
    occurred after the data were signed. Accepting data with no, wrong or unknown
    signature can lead to a corrupted system and in extreme cases even to a system
    compromise.

    Note: File 'repomd.xml' is the repositories master index file. It ensures the
    integrity of the whole repo.

    Warning: We can't verify that no one meddled with this file, so it might not be
    trustworthy anymore! You should not continue unless you know it's safe.

File 'repomd.xml' from repository 'Enpass' is unsigned, continue? [yes/no] (no):

What is the Problem here? When i enter yes it all works but you should mention this at the installation instructions.

Also when i sync with my webdav share, Enpass tell me that the certificate is not valid!? I run my own RootCA and the CA is imported in Firefox which should be fine, at least it was in Enpass 5.

Do you use a own Certificate Vault in Enpass 6? When yes, where can i import my RootCA?

Greets

Edited by Psyko
SPAM Protection
Link to comment
Share on other sites

Confirmed, i've deleted the repo and add it again -> no more errors when i do a sudo zypper ref! Great.

Also i add my own rootCA to /etc/pki/trust/anchors/ and run a sudo update-ca-certificates and now enpass connect without ssl errors!

Solved and thank you very much!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Privacy Policy