Jump to content
Sign in to follow this  
SecurityEnthusiast

Autofill on Ubuntu in Chromium-based (Brave) browser not working as expected

Recommended Posts

I've installed Enpass for Linux, installed the Chrome extension (for the Chromium-based Brave browser), and set Ctrl-/ to point to

/opt/enpass/Enpass showassistant

When I go to any login page, when I press Ctrl-/, it brings up the "generic" Enpass widget, the one that appears without having already done a search for the website I'm on--as if I hadn't given Brave permission to access Enpass. (By the way, when I hover over the Enpass extension button in the browser toolbar, the toolbar says "Enpass Password Manager Has access to this site". So lack of access isn't the problem.) When I double-click on the entry for the website, it doesn't autofill the current page, it opens the stored URL for the website and attempts to perform an autofill there (which doesn't always work, i.e., not if the login form is in a JavaScript modal that needs activating).

However, if I press the extension button in the browser toolbar, then it works as expected. I installed Enpass on my Windows partition and it worked fine (in Brave) there, i.e., when I press Ctrl-/ it does the expected search, and double-clicking on the website entry autofills the form on the page I'm on.

How can get Ctrl-/ to work on Linux/Ubuntu/Brave?

While I'm here, maybe you can answer a second question for me... Whenever I press Ctrl-/, it just brings up the widget. To actually activate autofill, I have to double-click on the name of the Enpass entry for the site. I can't tab to it, I can't press "enter" to select the top result, I don't know of any further keyboard shortcuts to avoid making the hated trip to the mouse. Is there any way to avoid double-clicking with the mouse?

Edited by SecurityEnthusiast
More copyediting for clarity

Share this post


Link to post
Share on other sites

Hi @SecurityEnthusiast,

What you have set as "Ctrl+/" is called global shortcut/hotkey. It is there to invoke Enpass Assistant at any point of time regardless of weather a browser active or not. It will not filter based on url of browser.

What you need to set is browser extension shortcut. In your browser go to "Options" of Enpass Extension (by right click on Enpass Extension button), and set a shortcut there. Remove "Ctrl+/" from global shortcut/hotkey first if you want to use the same combination for Extension.

13 hours ago, SecurityEnthusiast said:

While I'm here, maybe you can answer a second question for me... Whenever I press Ctrl-/, it just brings up the widget. To actually activate auto-fill, I have to double-click on the name of the Enpass entry for the site. I can't tab to it, I can't press "enter" to select the top result, I don't know of any further keyboard shortcuts to avoid making the hated trip to the mouse. Is there any way to avoid double-clicking with the mouse? 

Improvements are coming in next update for auto-filling.

Thanks.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...