Jump to content
Enpass Discussion Forum

Inconsistent docs for importing 1password vault


Recommended Posts

Hello. I was trying to import my 1Password vault to enpass. I found this documentation: https://www.enpass.io/docs/desktop-mac/import_1password.html

But, it appears to be slightly out of date. For one, the menu options don't match the docs.

  • The first step of Import wizard is to select the 1Password from the list and click Continue.

Whereas, if you look at the screenshot, enpass has two different options.

  • 1Password (Agilekeychain)
  • 1Password (OPVault)

For me, 1Password exported my vault as a directory: `1Password 2017-01-09, 07_37 PM (290 items and 2 folders).1pif`. I tried to import the directory with both 1Password modes, but neither of them would enable the "Open" button in the import dialog.

What finally worked for me was when I imported `1Password 2017-01-09, 07_37 PM (290 items and 2 folders).1pif/data.1pif`. Meaning, import the file `data.1pif`, which was _inside_ of the exported vault directory that 1Password created. Using the "Agilekeychain" import mode worked. The "OPVault" option didn't work.

Hopefully, this unblocks anyone trying to migrate from 1Password to enpass. Also, can someone please update the docs? :D

1Password: v6.5.3; enpass: v5.4.1; macOS: v10.12.3


Edited by fux0em
Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...