Jump to content
Sign in to follow this  
jasn

[Solved] Gentoo/KDE - Enpass 5.4.1 - QSQLCIPHER Error (DB won't open) - Browser Connection Error

Recommended Posts

Hello,

I'm having two problems with Enpass 5.4.1 on a new Gentoo Linux / KDE Plasma 5 system. The initial installation works fine and I can sync and open my wallet without issue.

However, the first problem is that I cannot get a connection to any browser. I've tried Firefox, Chromium, and Vivaldi, with the plugin installed from their respective official sites, and they all give the Enpass connection error page. The only similar thread reporting this problem here is this one, and they mentioned that starting Enpass first, and then the browser, worked for them, however it doesn't work for me in this case.

The second problem is that after a reboot, the Enpass app autostarts, (without my setting this in the app), and asks me to unlock my wallet. It won't recognize my master password, and I get the "QSQLCIPHER driver not loaded" error message in my .xsession-errors file, as reported in these two threads, (1., 2.), and probably this one too. If I uninstall the Enpass application, and delete my data, then I can reinstall and resync, and everything is fine, until I reboot. BTW, after the reboot, when I enter my master password into Enpass, the following lines are generated in my .xsession-errors;

QSqlDatabase: QSQLCIPHER driver not loaded
QSqlDatabase: available drivers: QSQLITE QMYSQL QMYSQL3

In terms of installation, there is an unofficial Gentoo ebuild maintained in the ssnb overlay, here, which I used to install Enpass 5.4.1. In the Gentoo ebuild system you can rename the ebuild to the current version number, and it will typically install the named version. So even though the last Enpass ebuild in the ssnb overlay is for version 5.3, renaming it to 5.4.1, and installing it in my local overlay, allowed me to install Enpass 5.4.1 successfully, (in /opt/Enpass). However, I also downloaded the Enpass Linux installer and followed the instructions here, which don't specify running the installer as root, and the app was in installed in my user home directory.

Feel free to ask for any additional information that may help identify these problems. At this point, an answer to the second issue is the higher priority, as, for the time being, I can live with the first. Also I have two questions regarding Enpass;

1) Is it recommended to install the app for all users? (If so, does running the Enpass installer as sudo/root accomplish this?) Or should the Enpass installer be run as a user, and installed in the user's directory structure?

2) How can Enpass autostart when I didn't enable it? There is nothing in my ~/.config/autostart directory. Does the Enpass autostart option install an autostart file somewhere else? Where should I look?

Thanks..

Edited by jasn
Solution provided

Share this post


Link to post
Share on other sites

I performed a clean install of 5.4.1 using the Enpass installer, in favor of the Gentoo ebuild. One of the reasons is that the installer installs a decent uninstall tool, which does not get installed with the Gentoo ebuild. I also specifically installed the software as sudo/root, and installed Enpass into /opt/Enpass.

I think that I recreated the "QSQLCIPHER driver not loaded" condition when I specifically select the "Minimize App to System Tray" option in the Enpass settings. Prior to selecting that option, I rebooted my system several times and Enpass didn't autostart, and I could open my wallet without issue. Then I selected "Minimize App to System Tray", and reboot, and Enpass autostarts, and generates the error condition described.

Then I decided to try the Linux 5.5 beta, and I configured it with the "Minimize App to System Tray" option, and rebooted, and it appears to be working correctly. I'm not sure this is the issue, but if anyone else is experiencing similar issues, they can try uninstalling Enpass and the Enpass data, and then reinstalling the app completely. Then after running Enpass, don't select the "Minimize App to System Tray" option, and see if Enpass works correctly through a reboot of the system. Alternatively you can try the beta 5.5 to see if this addresses the issue.

As far as the browser connection error, still no fix for this issue on my system.

Thanks..

Edited by jasn

Share this post


Link to post
Share on other sites

Hi @jasn,

Thanks for trying Enpass on gentoo. 

You should install "lsof" as a dependency to fix browser connection error. Also, the proper way to autostart Enpass on system reboot is to enable "Autostart on system startup" option in Enpass settings. Other methods for auto-starting will lead to launch incorrect binary without properly initialing Enpass environment and hence "QSQLCIPHER driver not loaded" error. 

Cheers

Screenshot from 2017-02-22 16-03-57.png

  • Like 1

Share this post


Link to post
Share on other sites

Thanks very much Vinod.

Installing sys-process/lsof and then a reboot, indeed fixed my browser connection issue completely. Now everything appears to be working fine.

In terms of the "QSQLCIPHER driver not loaded" error condition, I'm not sure exactly what the issue was. The thing I was seeing was when I selected "Minimize App to System Tray", the app would autorun, (even though I had not selected it to), and I would get the error condition described. I was confused as to how exactly Enpass could be set to autorun, when I had not specifically selected it.

Right now I'm running the 5.5 beta, with "Minimize App to System Tray" selected, (and not autorun), and everything appears to be working correctly, so I'll keep it there for now.

Thanks again,

Jason

Share this post


Link to post
Share on other sites

I was bugged by the same issue and it's to confirm that `emerge sys-process/lsof` (then restart Enpass & Chrome) has fixed the issue.

Thank you, I love the product.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...