Jump to content

Recommended Posts

I'm also experiencing this problem with Enpass Chrome extension and the Vivaldi browser (1.0.435.52).  I do have the Enpass 5.0.5 deskop client installed and working fine, on Windows 10.  The error I receive in Vivivaldi when clicking on the Enpass extension is:

Error 403 Access Denied/Forbidden

Browser's code signature could not be verfied. Filling and other features are disabled until this configuration issue is resolved.

 

 

Share this post


Link to post
Share on other sites

Hello guys,

You can make Enpass extension work with Vivaldi browser by turning off the Code signature verification in main Enpass App as explained here in user manual. Before that, just have a look at the whole scenario and associated risks (if any, in your case) in turning off the Browser verification. 

Currently Enpass supports extensions for widely used browsers; Chrome, Firefox, Safari and Opera browser. However the Enpass extension can be installed in many other Chromium based Web browsers available in market, provided they support installation of Chrome extensions (Here Vivaldi browser is your case). So as mentioned here under Communication section, Enpass App validates authenticity of both extension and Browser before making any connection and serving data for autofilling. In case of Vivaldi Browser, Extension Validity Check gets passed but the validity check for Browser gets failed and you get the Error 403. So if you turn off the code signature verification, you can bypass the Browser checking and set your foot into autofilling in Vivaldi Browser. 

To avoid any security risks associated with turning off the code signature verification, please make sure that you download the browser from the legitimate source and double check the authenticity of any extension you install.

Hope it helps!

  • Like 1

Share this post


Link to post
Share on other sites

Hey, there!

I have a comment here. ATM running Linux Mint (17.3) and I do have an issue with extension's communication with the app, however, It does work with chromium (chrome)!

So, the extension (in Vivaldi:latest) opens a new tab saying "Enpass Connection Error". Yes, "Verify browser" is disabled on linux.

Any comments, suggestions? 

 

P.S. Enpass is a really great piece of software! Like it a lot! :)

Share this post


Link to post
Share on other sites
10 hours ago, Ruslan said:

Hey, there!

I have a comment here. ATM running Linux Mint (17.3) and I do have an issue with extension's communication with the app, however, It does work with chromium (chrome)!

So, the extension (in Vivaldi:latest) opens a new tab saying "Enpass Connection Error". Yes, "Verify browser" is disabled on linux.

Any comments, suggestions? 

 

P.S. Enpass is a really great piece of software! Like it a lot! :)

Wanted to notice, that the same combination works just fine on ubuntu 14.04.

Share this post


Link to post
Share on other sites
Guest Ankur Sahu

Hi @Ruslan

We can understand your concern for Vivaldi browser even if the Code signature verification is disabled. The issue is with some API events in Chrome that are not working properly for Vivaldi due to failure in attempting a socket-connection. A possible work around is to start Enpass before starting the Vivaldi browser.

On 19/04/2016 at 11:33 AM, Ruslan said:

Wanted to notice, that the same combination works just fine on ubuntu 14.04.

In this case you might be starting Enpass before the Vivaldi Browser.

Share this post


Link to post
Share on other sites

I have the same issue with Vivaldi and Slimjet browser on Xubuntu 14.04, 15.10, and 16.04. Both are based on chromium so I don't get it. I haven't tried other browsers but I'm sure they work. 

Share this post


Link to post
Share on other sites

@Ankur Sahu,

Thank you! Yes, it does the trick!

 

On uBuntu, it doesn't matter, but on Mint (17.3) it does. Enpass has to be started before the Vivaldi!

 

For the rest of the users, who run into this problem, I do suggest to put it in the auto startup! Just so you do not have to worry about this issue!!! :) 

  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, kar82 said:

Hello,

I have open a bug-report in bug-tracker of Vivaldi: VB-17167

 

Hi @kar82,

Thanks a lot. So is it working now with this trick at your end after our discussion in Vivaldi's Forum?

 

Share this post


Link to post
Share on other sites

Yes, it's working with the "workaround".

I started the Enpass desktop client anyway at boot, so it's no problem for me. But it should working too, if you first starting Vivaldi (with installed Enpass extension) and then starting the Enpass desktop client, that's why I have open a bug-report in Vivaldi's bug-tracker.

Here is the link for our discussion in Vivaldi's  forum: https://vivaldi.net/en-US/forum/3rd-party-extensions/10885-enpass-extension-is-not-working

Edited by kar82
  • Like 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...