Jump to content
vampyren

Evaluating and found an error i think...

Recommended Posts

Hello, 

I just downloaded this app on my Windows PC and my iPhone 11. 

One very important feature that must work for me is Windows Hello which allows me to unlock using fingerprint.

I went into Settings-->Security and enabled "Windows Hello". But it seems when i start Enpass it does not let me login with "Windows Hello".

But once i login using the password and minimize and open again then i see the "Windows Hello" icon on the right corner. When i click on this icon then 

i can use fingerprint to login. This seems like a bug to me. Can you please confirm? 

Also why do i need to click on the icon, by default "Windows Hello" should be enabled and asking for fingerprint when i start Enpass both first start and also from minimized. 

This is the expected behavior. Can you please change that?

Question: where exactly does Enpass store the database on iCloud if i sync there? I check the folders there but cant find anything.

My system:

  • My PC: win10 x64 1909 (all latest patched)
  • Enpass: 6.4.1 (642)

 

I'm still evaluating the program before i purchase but so far i like what i see :) , really like i can choose backup/sync storage and there is no montly fee. That is a deal-breaker for me. I rather pay upfront!

Cheers

Edited by vampyren
Added question

Share this post


Link to post
Share on other sites

Hey @vampyren

Welcome to the forum!

Regarding Windows Hello issue- I would like to inform you that currently, Enpass asks for the master password in these scenarios even if you have enabled the Windows Hello:

  • System re-start
  • When you quit Enpass and starts fresh

However, we do have plans to improve the 'Windows Hello' functionality for full-time support and update with the fixes will be available with the subsequent update.

Regarding iCloud query I would like to share that for iCloud sync, Enpass uses the Cloud kit which saves the data internally. It's hidden and only the Enpass app can access its data saved in iCloud.

Thanks for your understanding!

Share this post


Link to post
Share on other sites

Hello,

Regarding Windows Hello issue:
Good to hear that its planned to be "fixed"

Regarding iCloud query-
I dont understand why? Its my data so why hide it so i can not access? i thought the whole idea was to users to decide where they want their data. If i can not access it then it might as well be on your server so whats the difference or point? 
I use also mSecure  which i'm switching from and they use a folder i can access so this is what i was expecting to be honest. I hope this can also be changed (maybe an option in the program so users can choose, maybe by hiding you add more security but again its should be users choice). Hope you understand my point?

I have not tried but how is it if i save my database on onedrive? is it also hidded? I read on forum that there were some issue with onedrive so i choose iCloud, not sure which is the best or preferred by Enpass? 

Share this post


Link to post
Share on other sites

Hi @vampyren,

Thanks for writing back in.

The Enpass API for iCloud/Google Drive uses the Cloud kit, which saves the data internally. It's hidden, and only the Enpass app can access its data collected in Cloud. If you want to check the Enpass encrypted file, which is saved in your Cloud, then you must sync with any other cloud-like OneDrive, Dropbox, or Box.

I hope this can also be changed (maybe an option in the program so users can choose, maybe by hiding you add more security but again its should be users choice). Hope you understand my point?

We have noted down your valuable suggestion and forwarded it to the concerned team for further consideration. Thanks for your feedback!

Share this post


Link to post
Share on other sites

Thank you for the info Pratyush I'm assuming the API for cloud kit makes it easier to work with syncing. Hopefully it can be visible in the future. What online storage is the most reliable in your experience choosing between iCloud and OneDrive? I use both of these regularly so i'm deciding which one i should use. 

I have now purchased the premium since i really like the program and it has some nice features compared to my old program that is a bit outdated. 

By the way, I found some strange behavior like when i copy a password it dont copy it to clipboard. Happened several times. 
Also once it copied something else into the clipboard after 3 tries it copied the right data. Very strange. Its hard to reproduce, it happens random! 

Share this post


Link to post
Share on other sites

Hi @vampyren,

Thanks for writing back in.

We recommend all the supported cloud to sync data. As you want to check the sync file, then you must use OneDrive. If you face any issue, let us know.
By the way, I found some strange behavior like when I copy a password it dont copy it to clipboard. Happened several times.
Also once it copied something else into the clipboard after 3 tries it copied the right data. Very strange. Its hard to reproduce, it happens random!

Please let us know what steps you are performing so we can investigate at our end. Also, let us know in which device you are facing this issue and which Enpass version you are using.

Thanks for your co-operation.

 

Share this post


Link to post
Share on other sites

I have had the issue in windows10  x64 build 1909 and my iphone 11 pro.

On Windows i think i might know why. I go to the Enpass icon on the notification icon and find something i want the password for and click on it and right click and copy password, sometime i tried shortcut Shift-Ctrl+p

I just now noticed that when i open Enpass icon on the notification icon when i hover the mouse over different sites it mark the item but does not actually select them, it must be dark blue before it actually select the item. Maybe this is what i did wrong. I will try some more and get back. 

Downloaded Enpass this week so latest version. 

Edited by vampyren

Share this post


Link to post
Share on other sites

Hello again, 

I have now found at least 2 bugs and some other annoying issues on the windows 10 app. Here are the details: 

Bug 1 & 2:

Start with the + sign to add a new item-->Login->Default

Step1: Press the "Generate" to show the password generation window. 

Error1:
Here if i right away click on "Fill", then the windows goes away and the password i was just seeing is changed. 
Expected Result:
The password that was shown must be kept

Error2:
If i instead click on "Copy to clipboard", again the password shown is changed!
Expected Result:
The password that was shown must be kept + copied to clipboard
-------------------------

Bug 3:

The Password field behaves very non-standard. Like i cant double click to select all the text, i cant click CTRL-A to select all the text and i cant even hold the left mouse and drag over the text to select the text. 
Expected Behavior:
Standard windows behavior should be available. 

Could you please look into these? maybe they are already reported? Any fix in the pipe? 

Step1.JPG

Step 1.1.JPG

Edited by vampyren

Share this post


Link to post
Share on other sites

Hey @vampyren

Sorry for the inconvenience caused to you.

We are already aware of this issue. Our Dev team is working on it and the update with the fixes will be available soon. Please stay tuned for the new update and let us know if the problem still persists after the updated version.

Thanks for understanding!

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...