Jump to content
CLC

"Error while restoring data" from Dropbox

Recommended Posts

I am running Enpass on Windows 10 (version from the Microsoft Store).  It has suddenly stopped syncing with Dropbox, although had been working previously.

I eventually uninstalled and reinstalled the program, but still have the same problem.

1. I can connect to Dropbox and Enable access successfully.  When I select Open Enpass Password Manager in the browser, the Enpass App then tries to connect to Dropbox but returns the message: "Error while restoring data".  Everything else is working normally, including network connections etc.

2. In the absence of the Dropbox link, I restored from a local backup and then tried to register.  Interestingly, when I tried to register the installation, Dropbox returned the message "No Internet Connection"!  Yet, my internet connection is working just fine.  I have tried disabling the firewall, but that made no difference.  In any event, Enpass has specific permission to penetrate the firewall, so that is not the problem.  So if the internet connection is working, and the firewall is not the problem, why can't Enpass see/use the internet connection?

What can I do to get Enpass to connect with Dropbox again?

Thank you for your help.

Enpass Error While Restoring Data.jpg

No Internet Connection.jpg

Edited by CLC

Share this post


Link to post
Share on other sites

Hi @CLC

We are sorry for the inconvenience caused to you.

It seems that any third-party app is blocking Enpass to connect with internet. Please let us know are you using any proxy/firewall or Antivirus, which is blocking Enpass to establish connection to the internet.

Thanks.

 

Share this post


Link to post
Share on other sites

Hi Garima,

As I mentioned in my original post, there is no firewall or antivirus blocking the program, of which I am aware.

Share this post


Link to post
Share on other sites

Hey @CLC

Thanks for writing back.

To check if Enpass have an internet connection, please follow these steps:

1. Right-click on the password field in the item → Select Check if Pwned from the options menu.
2. On the next screen, you’ll see a message to validate the operation. Click Continue and check if it successfully gives output or showing any error message.

Please also let us know the following details so we can help you better:

  • Are you able to register on any other device?

Thanks for the co-operation.

Share this post


Link to post
Share on other sites

Garima, the Check if Pwned test comes up with the message "SSL connect error".  All the other applications on my computer are having no problem connecting to the internet, so this problem seems to be specific to Enpass. 

I am able to connect to Enpass on my other devices (eg. Android phone.) without any problem.

Share this post


Link to post
Share on other sites

Hi @CLC

Thanks for sharing the details.

It seems that firewall is blocking Enpass to connect with internet. Please disable the same and check if the problem still persists.

Thanks for your cooperation.

Share this post


Link to post
Share on other sites

Hi Garima,

Point 2. of my original post said "I have tried disabling the firewall, but that made no difference.  In any event, Enpass has specific permission to penetrate the firewall, so that is not the problem."

I just uninstalled the program again; used Revo uninstaller to remove the remnants; used CCleaner to clean the registry; manually cleaned the registry by removing all references to Enpass ... then reinstalled the program.  No change.

I tried again with the firewall disabled, with the same result.  I have attached 3 screenshots showing the firewall disabled, Enpass having the rights to traverse the firewall, and the error which still comes up - SSL connect error.

None of my other programs are having a problem connecting to the internet.  What other settings could prevent Enpass from connecting?

Firewall OFF.jpg

Apps through Firewall.jpg

Pwned - SSL connection error.jpg

Edited by CLC

Share this post


Link to post
Share on other sites

Hi @CLC,

Thanks for your prompt reply and sorry for the trouble you're facing.
It seems that any app or third party software (Antivirus, proxy, firewall) is blocking Enpass to communicate with the internet. Could you please try restoring the data form cloud after altogether disable Firewall, Antivirus, or any network blocking software.
If the above steps don't help, could you please check if the Outbound Rules for Enpass is disabled in Windows Firewall settings. To check, please follow these steps:

  • Open Windows Firewall settings → Advanced settings→ Outbound Rules → Enpass password manager and check.

 Also, please let me know the Antivirus if you're using so that we can investigate further.
Thanks for your co-operation.

Share this post


Link to post
Share on other sites

Hi @Mvdveen,

Sorry for the inconvenience caused to you.

To check if Enpass have an internet connection, please follow these steps:

1. Right-click on the password field in the item → Select Check if Pwned from the options menu.
2. On the next screen, you’ll see a message to validate the operation. Click Continue and check if it successfully gives output or showing any error message.

Please also let us know the following details so we can help you better:

  • On which device (along with OS version) are you using Enpass?
  • Which Enpass version are you using?
  • Are you able to register on any other device?

Thanks for the co-operation.

Share this post


Link to post
Share on other sites

Thank you for your reply. 

As I will be offline for the next couple of months, I am unable to continue testing and we will need to pick this issue up again in September.

Best wishes.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Pratyush,

I am back now and still need to resolve this problem. 

I disabled the Win 10 Firewall (Defender) and also checked the Enpass has permission to traverse the firewall.  Outbound rules permit Enpass to communicate.  Disabling the firewall makes no difference and Enpass is still blocked.  Enpass is the only program which is unable to reach the internet.

When I check the password If Pwned, Enpass still replies with "SSL Connect Error"

Please see Screenshots attached.

How can we fix this?

Thanks for your help.

Firewall Off W10.jpg

Firewall Permission.jpg

SSL Connect Error.jpg

Outbound Rules.jpg

Share this post


Link to post
Share on other sites

Dear Pratyush,

Continuing from my prior message, I uninstalled and reinstalled Enpass using the Microsoft Store.  

image.png.9ade08244b729f6018db6452ba2f0cee.png

I get the message "Error while restoring data". 

image.png.7cdbd20aaf472a234788b979deb428bf.png

The only way to run Enpass is with a Backup file, but this is useless to me as it means my different devices are no longer syncing Enpass changes with each other.

 

Share this post


Link to post
Share on other sites

Dear Pratyush,

I tried syncing Enpass with Dropbox again today, and suddenly the syncing with Dropbox again.  I haven't changed anything since yesterday, so the reason for this this is a mystery.

Anyway, the problem seems to be solved for now.

Thanks.

Share this post


Link to post
Share on other sites

Hi Pratyush,

Well that solution didn't last long.  Enpass has stopped syncing again.  It is now showing Error code 204035.

1379764038_ErrorCode204035.jpg.de6ff58caf02fddf97af1dad5745251d.jpg

 

What does this error code mean?

Edited by CLC

Share this post


Link to post
Share on other sites

Hey @CLC

Thanks for the email.

Please follow these troubleshooting steps and let me know if the problem persists.
1. Turn off the sync from all devices.
2. Open Dropbox on any browser --> Go to App --> Open Enpass folder --> Select vault.enpassdbsync file --> Rename it as oldvault.enpassdbsync file.
3. Now open Enpass and enable sync on all the devices.

I hope this helps!

Share this post


Link to post
Share on other sites

Hi Garima,

I turned off sync and renamed the file on Dropbox, as you suggested.  I then resynced my devices, but nothing has changed.  All of the devices, apart from my PC, can sync with Dropbox just as they did before.

The PC simply says "Please wait..." but never moves on - Enpass waits forever on Set up Sync...

image.png.7d55931de94c589225428c32059bcb2a.png

Share this post


Link to post
Share on other sites

Hi Garima,

I have given up trying to resolve this problem and have reinstalled Windows.  Problem solved!

Thanks anyway for your help.

  • Like 1

Share this post


Link to post
Share on other sites

Hi all:

I doubt that reinstalling Window solved the issue. I do face exactly the same problem but on a Linux host (Fedora 32). Syncing itself seems to be fine (got another Fedora based box which works and the sync on Android also works), but the backup restore seems to be broken.

There is neither a firewall nor a proxy of any sort in the way. Latest version (v6.4.1.643) of Enpass is installed, operating system is also update to date.

Share this post


Link to post
Share on other sites

Hey @ch1r0x

Welcome to the forum!

Apologies for the inconvenience caused to you. Please share the following details so that we can investigate where the problem could be.

  • On which all devices and OS versions (mention all) are you using Enpass?
  • Which Enpass version are you using on each device?
  • Please share the screenshot of error message or code you getting?
  • Are you able to access all Enpass data on any of the device?
  • Does the Date and Time setting set to automatic on all devices?
  • Does the last synced time get updated on the sync page?

Thanks!

Share this post


Link to post
Share on other sites

Hi Garima,

there are two additional devices (one laptop, one mobile phone) but for those the synchronization is working fine as already mentioned.

The issue exists on a newly setup workstation on which I try to restore my data from a Dropbox account, but which fails with the very same error as in: https://discussion.enpass.io/index.php?/topic/20017-error-while-restoring-data-from-dropbox/&do=findComment&comment=37908

Laptop and workstation have exactly the same configuration. OS and Enpass versions I have mentioned in my prior comment, but it's Fedora 32, Enpass v6.4.1.643.

And I'm not talking about synchronization, but a backup restore from a dropbox account.

By the way, I do have a lifetime license.

Cheers

Edited by ch1r0x

Share this post


Link to post
Share on other sites

Hey @ch1r0x

Thanks for sharing the details.

Please follow the below steps to transfer(restore) the data from other device to Linux device and let me know if you have any concerns-

  • Take the complete backup of Enpass data from your other device using these steps. Open Enpass > Click on 'Backup all vaults' from the menu > Select the location and save it.
  • Now login to your cloud account on the same device and upload the backup folder in the Enpass app folder of the cloud.
  • Now login to your cloud account on your Linux device, download the same backup folder data and save it locally.
  • Open Enpass on your Linux device--> Settings --> Advanced --> Apply Erase Everything function > when the Welcome screen appears, restore the data from the backup file saved locally. Note: Before uninstalling the app make sure you already have the backup of Enpass data (if you have any).

Share this post


Link to post
Share on other sites

Hey @Garima Singh

I just want to let you know that I resolved my issue by simply copying over all the relevant files from the other Linux host.

Although I'm not any longer affected, probably someone should investigate the backup restore issue.

Thanks for your help.

Cheers

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...