Jump to content
simonb

Enpass crashes after sleep on MacOS

Recommended Posts

Enpass has always worked very well for me, but recently it's started crashing every time my Mac Book Pro awakes from sleep.

I'm on Sierra 10.12.6, mid-2015 MBP 15" i7 16GB.

Share this post


Link to post
Share on other sites

Hi @simonb,

Sorry to hear about your trouble you are going through. I would really appreciate if you can please mention the exact steps performed those led to crash after you wakes up your Mac.

Also, it would be a great help if you can share the crash report at support@enpass.io so that we can diagnosis where the problem could be.

Thanks for your co-operation!

Share this post


Link to post
Share on other sites

Hi Anshu

Just about to email you a crash report. Here are the steps involved:

  1. Start up computer,
  2. Log in to Enpass,
  3. Use browser and Enpass as normal,
  4. Close browser,
  5. Close lid of computer,
  6. Open computer about 10 minutes later,
  7. Enpass crashes (see attached screenshot),
  8. Click Reopen, log in to Enpass
  9. All is fine again

Cheers, Simon

Screen Shot 2017-10-11 at 09.27.15.png

Share this post


Link to post
Share on other sites
Guest Akash Vyas

Hey @simonb

Thanks for sharing the detailed steps and the crash report for the issue. I've shared it with the tech team so that they can look into it further.

Top of the day to you!

Share this post


Link to post
Share on other sites

I can confirm same on my side. Mac OS High Sierra. 

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000010
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [0]

 

Problem Report for Enpass 2017-10-16 12-19-16.jpg

Share this post


Link to post
Share on other sites

I, too, see the reported regular crashes. This has not been resolved in the last three Enpass updates.

I have seen these issues with MacOS 10.13; 10.13.2 and 10.13.3.

What is the current status on fixing this, Anshu? I love your product but this issue is really annoying.

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...