Jump to content
Enpass Discussion Forum

Strange behavior in Firefox on Windows with Enpass extension version 6.6.0


Recommended Posts

With the automatic update of the Enpass Firefox extension to version 6.6.0 today, I get a strange behaviour, if I press the enter key on some text input fields on some pages.

For example on the website https://joker.com. I try to login, press the enter key in the password field and instead of getting logged in, the cursor jumps to an unrelated search form on the bottom of the page. This only happens, when the extension is active. If I deactivate the extension, everything is back to normal.

This also happens on other text input fields on the page, which have some javascript actions bound on the enter key in a key-up event. If I press enter, some other form field on the website gets the focus and the javascript action is not executed.

If I deactivate the Enpass extension, everything is back to normal.

Please fix this.

Link to post
Share on other sites

In run Windows 10 Version 2004 (x64) on my desktop computer with Firefox Version 86.0 (64 Bit). The Version of the Enpass Extension in Firefox is 6.6.0 and the Enpass Version is also 6.6.0.

The simplest way to reprodruce the issue is: Goto https://joker.com/user/login and type anything into the login name field and press the enter key. The the focus will jump to the bottom of the page, if the plugin is active. If you deactivate the plugin, the focus will move to the password field.

I managed to downgrade to Version 6.5.2 of the Firefox extension from a Windows backup to not have those issues and still be able to use Enpass.

My colleague has similar issues with Safari and the latest Enpass version on macOS Big Sur. I will ask him for more details, if you need that.

Link to post
Share on other sites
  • 3 weeks later...

If the issue is fixed, do you have any ETA for releasing updated extensions? By the way, this happens to me on multiple browsers (Safari, Chrome, Edge, Firefox), so this issue affects all those extensions.

Link to post
Share on other sites
  • 3 weeks later...

Hi @Garima Singh, hi @Pratyush Sharma,

I guess there is no update yet? This is really frustrating and I don't understand, why you are waiting to release a fix for this issue.
I had to completely remove the extension from chrome, as it gets updated automatically on Chrome and I'm not able to work properly.

So an update about how long it will take would be nice...

Link to post
Share on other sites

I could understand this if they were having trouble fixing it, but they stated they have fixed the issue already, an annoying one at that, and they don't release it... It just makes no sense.

@Garima Singh @Pratyush Sharma That's a good approach if you want to alienate your users, and make them look for alternatives. Think about that.

Edited by rfgamaral
Link to post
Share on other sites
  • 3 weeks later...

I appreciate it takes time to release things sometimes, but having this released sooner rather than later would be great.

I recommend Enpass to users of the SaaS product I work on, but it is actively introducing buggy behavior by cycling through- and sending focus events to all sorts of input fields in the system. This then clashes with a JS date picker library which auto-fills every empty field with a bogus date, messing up all the data.

When they reach out for support I have to guide them through how to limit the extension's site access.

Link to post
Share on other sites

Hi any news on this?

I have the same issue in both Chrome and Firefox using latest 6.6.0 version of the extension.

The focus jumps to another field when pressing enter, usually a date field and in cases where enter key is the only way to submit as is often the case with column filters f.x. it renders them unusable since it prevents the key* events on the element.

Also I must say I have started to question my faith in enpass team. It is a great product but issues are being dealt with very slowly and also I cannot understand if the fix is already done, why wait such a long time to publish to the extension stores, is QA really taking +4weeks for a bug fix?

 

Last issue I was part of reporting took 5 weeks from fixing to publishing to extension stores

 

For this one seems already there are 8 weeks since fix was done still no sign of an update in the extension stores?

 

Don't get me wrong I love your product but this delay between bug fixes being done and them being deployed is really making me question if this is the correct platform for me.

  • Like 1
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...