Jump to content
Enpass Discussion Forum

OneDrive sync "could not verify credentials"


Recommended Posts


All of a sudden, Enpass 6.7.4 (933) running on Windows 10 cannot sync with my OneDrive account anymore. I click "set up sync," authenticate at login.microsoftonline.com for my OneDrive account, am taken to the "Authorization Finished!" screen where it then redirects back to the Enpass app. But it continually just says it can't verify. I have logged out and in a few times, and I've closed out Enpass completely and reopened. Not sure what else to try. Side note, "credintials" is misspelled in the error message.


Link to comment
Share on other sites

Hello @SportingChap,

I certainly understand your concern about not being able to sync your data with OneDrive across the devices. In order to resolve this issue, please perform the following steps and share the results:

  1. Take a manual backup of your data on all the devices.
  2. Disconnect the OneDrive sync from all your devices.
  3. Open OneDrive app/website → Go to App → Open Enpass folder → Select vault.enpassdbsync file → Rename it as oldvault.enpassbdsync.
  4. Reconnect the OneDrive sync on all the devices.
  5. If sync starts to work fine, you can delete the renamed old backup file from step 3.

If it does not help, please help me with the following details so that we can investigate it further:

  1. Have you recently changed your master password?
  2. Make sure the date & time are the same across the devices. 
  3. Let me know if you can access the OneDrive account and can see the Enpass folder there. 
Link to comment
Share on other sites

None of this worked. I have not recently changed my password. Date and times are correct. This issue started happening at the same time across all of my desktop devices: Windows 10 and MacOS. Android is not affected - sync is still working fine here. And yes, I can manually access the OneDrive account and the folder/vault file. No matter what I try on desktop I am getting the error message in the screenshot.

===== UPDATE =====

You are going to love this... I run Pi-hole on my home network, and turns out it was blocking the OneDrive sync. I didn't think to check this earlier since I've been running Pi-hole for almost a year now with no impact to Enpass. My guess is when gravity updated the blocklists on Sunday, one of them must have added something Microsoft related. (Or it's possible Microsoft recently altered how app authentication works.) Once I whitelisted these two domains it started syncing again:

  • graph.microsoft.com
  • ic3.events.data.microsoft.com

Lol, isn't I.T. fun! Thanks for the help. Love Enpass. :) 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...