Jump to content
Enpass Discussion Forum

Webdav path must not contain "Enpass" on macOS


hasch2k08

Recommended Posts

I've been using the webdav synchronisation for a while now and since my cloud provider changed its URL I had to set up the webdav sync on all my devices all over again. While doing that I noticed that Enpass on macOS always creates an additional subfolder called "Enpass" even if the webdav path already contains the word "Enpass". My android phone, Linux machines, windows machines, my iPad do not have the problem only Enpass on my MacBook air Early 2014 with macOS Big Sur does.

What is the problem in detail:
My webdav path used to be "https://mycloudProviderName.com/webdav/Enpass". In my cloud storage I've used to store my Enpass vault in a separate folder called "Enpass".  That's why the webdav path contained the word "Enpass". All my devices mentioned above store or sync my Enpass vault in the path "https://mycloudProviderName.com/webdav/Enpass/vault.enpassdbsync ". But not my MacBook air, Enpass on this machine stored the Enpass vault in "https://mycloudProviderName.com/webdav/Enpass/Enpass/vault.enpassdbsync". Which either meant that I had two different vaults stored in my cloud or one of my devices could not find the existing vault since the devices use different path in the cloud storage.

The work-around which works, but not as expected:
After I've understood the problem I've changed the folder structure in my cloud storage to "https://mycloudProviderName.com/webdav/Test123". Now the synchronisation between all the devices works just fine. But the data is stored in "https://mycloudProviderName.com/webdav/Test123/Enpass/vault.enpassdbsync". The additional subfolder "Enpass" which is now created or presumed, depending if the device creates the vault in the first place or just syncs with it, is used on all devices and not just on my MacBook. "Not great, not terrible" as Anatoli Djatlow would say (May god rest the soul of Paul Ritter).

Conclusions:
It seems to me that the urge to create a new subfolder called "Enpass" when syncing using webdav is in all Enpass apps on all operating systems. Unfortunately, only on macOS the Enpass app does not notice that Enpass is already in the provided webdav path. If you ask me Enpass should not create a subfolder for itself at all or at least not without asking.

I've been using Enpass for almost three years now and since I've been using webdav synchronisation from the beginning this bug must have been introduced after the February of 2019 or it is caused by one of the countless updates of macOS since then.

Link to comment
Share on other sites

Hi @hasch2k08,

Welcome to the Enpass community.

I have duly noted your steps, and it has been forwarded to the concerned team for further investigation. Meanwhile please share these following details.

  1. Which Enpass version are you using on your Macbook (Also, Is it a Store or website version)?
  2. If possible, share the Demo account of WebDav via PM or at support@enpass.io along with this forum link, which might help us identify the behavior at our end. 

#SI-2559

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...